Project

General

Profile

Feature #4048

Dump a JSON file about properties of generated DSE test cases

Added by Alexander Diewald about 2 months ago. Updated 5 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Start date:
07/24/2020
Due date:
% Done:

100%

Estimated time:
2.00 h

Description

General

The JSON file shall be dumped in the runtime WS to ease its discovery. Also, a separate file ensures that the generated information is not cluttered with other log messages.

Properties to include

  • Number of Components
  • Number of Generated constraints (per Constraint)
  • List of Constraint names

History

#1 Updated by Alexander Diewald about 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
MRs: Testing:

#2 Updated by Alexander Diewald 6 days ago

  • Assignee changed from Alexander Diewald to Simon Barner

#3 Updated by Simon Barner 6 days ago

The following problem occurred when testing:

java.lang.RuntimeException: The model at platform:/plugin/org.fortiss.af3.exploration//res/org/fortiss/af3/exploration/testgeneration/TemplateArchitectures.af3_23 requires manual migration.
    at org.fortiss.af3.project.utils.TestCaseProjectUtils.loadTestProject(TestCaseProjectUtils.java:65)
    at org.fortiss.af3.exploration.testgenerator.ExplorationTestCaseGenerator.generateTestCases(ExplorationTestCaseGenerator.java:78)
    at org.fortiss.af3.exploration.cli.TestCaseGenerationCommandLineHandler.handleCLISwitch(TestCaseGenerationCommandLineHandler.java:67)
    at org.fortiss.tooling.kernel.internal.CommandLineInterfaceService.executeHandlers(CommandLineInterfaceService.java:73)
    at org.fortiss.af3.rcp.application.advisors.ApplicationWorkbenchAdvisor.postStartup(ApplicationWorkbenchAdvisor.java:79)
    at org.eclipse.ui.internal.Workbench.lambda$18(Workbench.java:2836)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1115)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1049)
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
    at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:660)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:559)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
    at org.fortiss.af3.rcp.application.AF3Application.start(AF3Application.java:49)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.base/java.lang.reflect.Method.invoke(Method.java:566)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1438)

#4 Updated by Simon Barner 6 days ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Simon Barner to Alexander Diewald

#5 Updated by Alexander Diewald 6 days ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Alexander Diewald to Simon Barner

Cannot reproduce.

#6 Updated by Simon Barner 5 days ago

  • Assignee changed from Simon Barner to Johannes Eder

Issue above was fixed.

Merged, please close.

Also available in: Atom PDF