Project

General

Profile

Change Request #3886

Reduce MIRA to support minimal requirement features

Added by Johannes Eder 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Hackathon
Start date:
12/02/2019
Due date:
% Done:

100%

Estimated time:

Description

Refactoring of MIRA to remove all unmaintained features and to support only basic requirement features:
  • Hierarchy (Package structure)
  • Traces
  • Basic attributes
    • Name
    • Description
    • ...
  • Glossary

Related issues

Related to Change Request #3925: Remove requirements relations in MIRAClosed02/04/2020

History

#1 Updated by Andreas Bayha 10 months ago

  • Status changed from New to In Progress

#2 Updated by Johannes Eder 10 months ago

  • Assignee changed from Andreas Bayha to Johannes Eder

#3 Updated by Johannes Eder 10 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Johannes Eder to Simon Barner

Removed further classes.

#4 Updated by Simon Barner 10 months ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Simon Barner to Johannes Eder

Branch is not ready for review. Please:

  • (delta) review all modified to YELLOW
  • ensure modified classes have no (new) warnings (e.g., unused fields)

#5 Updated by Johannes Eder 10 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Johannes Eder to Simon Barner

#6 Updated by Simon Barner 10 months ago

  • Assignee changed from Simon Barner to Johannes Eder

Merged, please close.

#7 Updated by Johannes Eder 9 months ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

#8 Updated by Alexander Diewald 9 months ago

  • Status changed from Closed to Feedback
  • Assignee set to Johannes Eder

There seems to be an issue when loading the ACC model - I get the following exception. Could you please verify?

!ENTRY org.eclipse.core.jobs 4 2 2020-01-15 14:55:50.794
!MESSAGE An internal error occurred during: "Model Constraint Checker Job".
!STACK 0
java.lang.UnsupportedOperationException
at org.fortiss.af3.mira.model.impl.AnalysisImpl.getDefinitionElement(AnalysisImpl.java:555)
at org.fortiss.af3.project.utils.FunctionScopeUtils.getFunctionDefinition(FunctionScopeUtils.java:55)
at org.fortiss.af3.expression.language.TypeChecker.typecheckUserdefinedFunction(TypeChecker.java:308)
at org.fortiss.af3.expression.language.TypeChecker.typecheckExpression(TypeChecker.java:165)
at org.fortiss.af3.expression.language.TypeChecker.typecheck(TypeChecker.java:93)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.performTypeCheck(ComponentConstraintChecker.java:105)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.performPortCheck(ComponentConstraintChecker.java:86)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.collectViolations(ComponentConstraintChecker.java:57)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.collectViolations(ComponentConstraintChecker.java:1)
at org.fortiss.tooling.kernel.extension.base.MultiViolationConstraintCheckerBase.apply(MultiViolationConstraintCheckerBase.java:44)
at org.fortiss.tooling.kernel.internal.ConstraintCheckerService.performConstraintCheck(ConstraintCheckerService.java:125)
at org.fortiss.tooling.kernel.internal.ConstraintCheckerService.performAllConstraintChecksRecursively(ConstraintCheckerService.java:94)
at org.fortiss.tooling.kernel.ui.internal.MarkerService.refreshMarkers(MarkerService.java:196)
at org.fortiss.tooling.kernel.ui.internal.MarkerService$2.run(MarkerService.java:115)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

!ENTRY org.eclipse.core.jobs 4 2 2020-01-15 14:55:50.807
!MESSAGE An internal error occurred during: "Model Constraint Checker Job".
!STACK 0
java.lang.UnsupportedOperationException
at org.fortiss.af3.mira.model.impl.AnalysisImpl.getDefinitionElement(AnalysisImpl.java:555)
at org.fortiss.af3.project.utils.FunctionScopeUtils.getFunctionDefinition(FunctionScopeUtils.java:55)
at org.fortiss.af3.expression.language.TypeChecker.typecheckUserdefinedFunction(TypeChecker.java:308)
at org.fortiss.af3.expression.language.TypeChecker.typecheckExpression(TypeChecker.java:165)
at org.fortiss.af3.expression.language.TypeChecker.typecheck(TypeChecker.java:93)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.performTypeCheck(ComponentConstraintChecker.java:105)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.performPortCheck(ComponentConstraintChecker.java:86)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.collectViolations(ComponentConstraintChecker.java:57)
at org.fortiss.af3.component.constraint.ComponentConstraintChecker.collectViolations(ComponentConstraintChecker.java:1)
at org.fortiss.tooling.kernel.extension.base.MultiViolationConstraintCheckerBase.apply(MultiViolationConstraintCheckerBase.java:44)
at org.fortiss.tooling.kernel.internal.ConstraintCheckerService.performConstraintCheck(ConstraintCheckerService.java:125)
at org.fortiss.tooling.kernel.internal.ConstraintCheckerService.performAllConstraintChecksRecursively(ConstraintCheckerService.java:94)
at org.fortiss.tooling.kernel.ui.internal.MarkerService.refreshMarkers(MarkerService.java:196)
at org.fortiss.tooling.kernel.ui.internal.MarkerService$2.run(MarkerService.java:115)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

I would assume that the functions defined in the data dictionary point to some sub-node of a MIRA element.

#9 Updated by Johannes Eder 9 months ago

  • Assignee changed from Johannes Eder to Alexander Diewald

Should be gone now that the removal of FOCUSer has been done and merged into master. Could you please check again?

#10 Updated by Alexander Diewald 9 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Thanks for the pointer. The problem is indeed already solved (ouch!).

#11 Updated by Alexander Diewald 9 months ago

  • Assignee changed from Alexander Diewald to Johannes Eder

#12 Updated by Johannes Eder 8 months ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

#13 Updated by Johannes Eder 8 months ago

Also available in: Atom PDF