Project

General

Profile

Bug #3566

JVM crash with unsat cores

Added by Simon Barner almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
10/31/2018
Due date:
% Done:

100%

Estimated time:

Description

Steps to reproduce:

  • Import the Simple6-nodepl_constraints.af3_23 model from #3555
  • Active DSE perspective
  • Home -> Select / Change Project -> Simple6-nodepl_constraints-> NEW DSE -> Finish
  • Home -> Deployment
    • Select "Couple 1,2" rule set
    • Select "Decouple 1,2" rule set
    • Select "Enable joint schedule synthesis"
    • Select "Enable minimization of latency"
    • Generate
  • AF3 crashes completely due to an JVM access violation exception. See attached log file
hs_err_pid920.log (37.8 KB) hs_err_pid920.log Simon Barner, 10/31/2018 01:56 PM
hs_err_pid5896.log (37.7 KB) hs_err_pid5896.log Crash with TreeMap Simon Barner, 10/31/2018 04:22 PM

History

#1 Updated by Simon Barner almost 2 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 30

The following attempts did not succeed to resolve or workaround the error:

  • Upgrading Z3 to the latest version 4.8.1
  • Using a TreeMap instead of a HashMap. This results into a similar error (see new attachment hs_err_pid5896.log)

In order to have this issue resolved, a ticket will be filed for Z3.

#3 Updated by Simon Barner almost 2 years ago

  • Subject changed from Executing Deplo+Sched with infeasible constraint crashes JVM to JVM crash with unsat cores
  • Status changed from In Progress to Resolved
  • Assignee changed from Simon Barner to Alexander Diewald
  • % Done changed from 30 to 100

#4 Updated by Alexander Diewald almost 2 years ago

  • Assignee changed from Alexander Diewald to Anonymous

Merged. Please close.

#5 Updated by Anonymous almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF