Project

General

Profile

Change Request #3337

Replace af3.deployment with af3.allocation

Added by Simon Barner over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
02/21/2018
Due date:
02/26/2019
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

This collection issue must be refined with sub-issues for the individual tasks such as
  • Implementation of migrators
  • Adjustment of code generators
  • Finalization of adjustment of af3.schedule
  • Adjustment of safetycases
  • Adjustment of exploration

Subtasks

Change Request #3283: Replace Hop with SegmentClosed

Support #3601: [depl -> allocation] Test and review obcsaClosed

Support #3602: [depl -> allocation] Test and review safetycasesClosed

Support #3603: [depl -> allocation] Test and review scheduleClosed

Support #3604: [depl -> allocation] Test and review code generationClosed

Support #3605: [depl -> allocation] Test and deployment to ca2ta transformationClosed

Support #3613: [depl -> allocation] Test and review af3.exploration[.*]Closed

Support #3614: [depl -> allocation] Test and review af3.platform.raspberry[.ui]Closed

Support #3615: [depl -> allocation] Test and review af3.platform.javaberry[.ui]Closed

Support #3671: Merge and update build infrastructureClosed


Related issues

Blocked by Change Request #3319: Service Registrations : Handle ambiguity caused by generated EMF "Impl" typesClosed03/06/2018

History

#1 Updated by Simon Barner almost 2 years ago

  • Subject changed from Replace af3.deploymen with af3.allocation to Replace af3.deployment with af3.allocation
  • Status changed from New to In Progress
  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to AF3 2.15 RC1 (Feature Freeze)
  • % Done changed from 0 to 40

All changes are implemented in the 3337 of the respective repositories. The subtickets are used to track the progress of testing and code review.

#2 Updated by Simon Barner almost 2 years ago

  • Blocked by Change Request #3319: Service Registrations : Handle ambiguity caused by generated EMF "Impl" types added

#3 Updated by Simon Barner over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Simon Barner to Anonymous

Please close.

#4 Updated by Anonymous over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF