Project

General

Profile

Feature #3223

Feature #2658: Hierarchic Platform

Feature #3151: Communication Mapping

Allocation-based port mappings

Added by Simon Barner almost 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
12/07/2017
Due date:
% Done:

90%

Estimated time:

Description

Add replacements for
  • InputPortAllocation
  • OutputPortAllocation
  • TransceiverAllocation
  • TransceiverPortAllocation

that consider the allocation model (#2950)

ComMapTest.af3_23 (50.9 KB) ComMapTest.af3_23 Simon Barner, 09/24/2018 05:56 PM

History

#1 Updated by Simon Barner over 2 years ago

  • Status changed from New to In Progress
  • Target version changed from AF3 2.13 RC1 (Feature Freeze) to AF3 2.14 RC1 (Feature Freeze)
  • % Done changed from 0 to 50
It is possible to map ports between the following architectures
  • LA -> TA
  • LA -> PA
  • TA -> PA
Missing
  • TA -> HW
  • PA -> HW

Whether transceiver ports are still needed should be decided in #3256.

#2 Updated by Simon Barner about 2 years ago

  • File ComMapTest.af3_23 ComMapTest.af3_23 added
  • Subject changed from Deployment -> Allocation Migration: Communication aspects to Allocation-based port mappings
  • Status changed from In Progress to Resolved
  • Assignee changed from Simon Barner to Alexander Diewald
  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to AF3 2.15 RC1 (Feature Freeze)

Implemented in https://git.fortiss.org/af3/af3/merge_requests/92

Refer to attached test project that demonstrates the different cases.

Notes:
  • This ticket does not deal with the implementation of model migrators
  • The definition of an allocation-based metamodel to describe routes (VirtualLink@s in @Deployment nomenclature) is subject to #3256

#3 Updated by Alexander Diewald about 2 years ago

  • Status changed from Resolved to Feedback
  • Editor Behaviour
    • Is it intended that a "parent" port (Here: component -> task) can be mapped
      to the same TaskPort?
    • More generally: are there constraints that consider the hierarchy?
    • There are some constraints on the Partition Port --> Transceiver allocs that
      may be not intuitive: Could we place a note somewhere that only those allocs
      are available where a "Partition Channel" exists?
    • When interacting with the editor (ticking/unticking), the all other items are
      collapsed.
    • Port allocations are not updated if a task to partition allocation changed.
      This can be reproduced by unticking such an allocation --> The port
      allocation remains, but is not selectable any more if it is manually unset.
      Thus, when deselecting a Task --> Partition (or other allocs), the
      corresponding port mappings should be reset to avoid invalid models "by
      construction".

#4 Updated by Simon Barner about 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Alexander Diewald to Simon Barner

Working on suggested improvements.

#5 Updated by Simon Barner about 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Simon Barner to Alexander Diewald

#6 Updated by Alexander Diewald about 2 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Alexander Diewald to Simon Barner
  • % Done changed from 50 to 90

Just a small bug left: In the TA --> PA Allocation editor, Task OutputPorts can be mapped to arbitrary Partition OutputPorts irrespective of the Task --> Partition mapping.

And a small clarification (for me): Is it intended that Rows in the Port allocation tables are collapsed if an, e.g. Task --> Partition, allocation is deleted and reselected? This is the result of the update mechanism (tested). Not sure if it is even worth thinking about this...

All the other allocations seem to work fine. Great job!

#7 Updated by Simon Barner about 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Simon Barner to Alexander Diewald

Fixed.

#8 Updated by Simon Barner over 1 year ago

  • Assignee changed from Alexander Diewald to Anonymous

This has already been merged. Please close.

#9 Updated by Anonymous over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF