Project

General

Profile

Bug #2751

Change Request #3878: [UI] Collection task to switch gef based editors to the new JavaFX-based editors (LWFXEF)

Feature #3815: [Kernel] Add LWFXEF framework from SystemFOCUS to kernel.common.ui

Moving multiple components does not work with different zoom levels

Added by Andreas Bayha over 3 years ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
11/25/2016
Due date:
% Done:

100%

Estimated time:

Description

Reproduce:
- Import the attached model.
- Open "Green Field" Component Architecture.
- Zoom out to see all components (if you should see them already - zoom out anyway)
- Select all Components
- Move them

Observation: The components are moved far more than indicated or intended.

FestoMPS.af3_23 (234 KB) FestoMPS.af3_23 Andreas Bayha, 11/25/2016 02:18 PM

History

#2 Updated by Anonymous over 3 years ago

  • Assignee set to Alexander Diewald

#3 Updated by Alexander Diewald over 3 years ago

  • Status changed from New to Resolved
  • Assignee changed from Alexander Diewald to Andreas Bayha
  • % Done changed from 0 to 100

Please test. The behaviour is not yet completely correct (i.e., small mis-alignments & sometimes minor distance to the grid), but the moved elements are now almost aligned with the predicted position. Hence, the situation is definitely improved now.

Please also test different zoom levels: Zoom-in (1.5; 2.0), Zoom-out(0.75; 0.5).

#4 Updated by Anonymous over 3 years ago

  • Target version changed from AF3 2.11 GUI Improvement Week to AF3 2.12 GUI Sprint

#5 Updated by Anonymous over 2 years ago

  • Target version changed from AF3 2.12 GUI Sprint to AF3 2.13 RC1 (Feature Freeze)

If done is 100 % it should be marked as resolved

#6 Updated by Anonymous over 2 years ago

Sorry! it's already marked as resolved!
But then it should be assigned to Filip (specifying the classes to be reviewed)

#7 Updated by Alexander Diewald over 2 years ago

  • Status changed from Resolved to Feedback

It's r18956.

@Andreas: Is the behavior fine now?

#8 Updated by Johannes Eder about 1 year ago

  • Target version changed from AF3 2.13 RC1 (Feature Freeze) to Backlog

#9 Updated by Johannes Eder about 1 year ago

  • Target version changed from Backlog to AF3 2.16 RC1 (Feature Freeze)

#10 Updated by Johannes Eder about 1 year ago

  • Target version changed from AF3 2.16 RC1 (Feature Freeze) to AF3 2.16 RC2 (Tested, Bug-free)

#11 Updated by Simon Barner 10 months ago

  • Assignee changed from Andreas Bayha to Florian Hölzl
  • Target version changed from AF3 2.16 RC2 (Tested, Bug-free) to AF3 2.17 (Feature Freeze)

The problem persists. However, this bug does not have to be fixed since a re-implementation of the component editors is planned.

Re-assigning as a regression test for the implementation.

#12 Updated by Simon Barner 10 months ago

  • Parent task set to #3815

#13 Updated by Johannes Eder 6 months ago

  • Status changed from Feedback to Rejected
  • Assignee deleted (Florian Hölzl)

Rejected as we are now switching to JavaFX based editors.

#14 Updated by Johannes Eder 5 months ago

  • Target version changed from AF3 2.17 (Feature Freeze) to AF3 2.17 (Tested, Bug Free)

Also available in: Atom PDF