Project

General

Profile

Bug #2443

GC.copyArea() crashes application on OSX 10.11

Added by Anonymous almost 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
11/09/2015
Due date:
% Done:

0%

Estimated time:

Description

- Import the attached Model
- Start Simulation
- Try to open Input/Output view

(you need platform.dmils(.ui) for that

DMILS-Test.af3_23 (27.8 KB) DMILS-Test.af3_23 Anonymous, 11/09/2015 11:02 AM
Screen Shot 2015-11-24 at 11.46.24.png (45.2 KB) Screen Shot 2015-11-24 at 11.46.24.png Anonymous, 11/24/2015 11:51 AM
macos-table-checkbox-developer-installation-workaround.patch (2.27 KB) macos-table-checkbox-developer-installation-workaround.patch Workaround to avoid crash in developer version (DO NOT COMMIT) Simon Barner, 11/06/2017 05:28 PM
macos-table-checkbox-developer-installation-workaround (1).patch (2.32 KB) macos-table-checkbox-developer-installation-workaround (1).patch Anonymous, 12/04/2017 02:58 AM

History

#1 Updated by Anonymous almost 5 years ago

how "high" is that?

#2 Updated by Anonymous almost 5 years ago

That depends very strong on whether simulation is not working only for me or for everyone ...
I tested it with a fresh ACC model => same error

#3 Updated by Anonymous almost 5 years ago

I get the error (look at the screenshot and the error text below) no matter what i do. The annoying thing is, that Johannes doesn't get this error, which means either it my own fault or some OSX problem... Assuming that it is the latter one ;) I told Georgeta to try to reproduce this error on her mac. She will do so, when she will have time for it.

Here again the description of how reproduce the error:

1) load a fresh ACC model
2) Go to simulation view
3) Try to open Input/Output view

The error screen I get is attached (screenshot) and the console message i get is the following:

ava HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
Could not read metada. Probably simply not existing.
!SESSION 2015-11-24 11:45:38.910 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_60
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -product org.fortiss.af3.rcp.application.product
Command-line arguments: -product org.fortiss.af3.rcp.application.product -data /Users/zverlov/Documents/Development/af3workspace/../runtime-af3_phoenix.product123 -dev file:/Users/zverlov/Documents/Development/af3workspace/.metadata/.plugins/org.eclipse.pde.core/af3_phoenix.product/dev.properties -os macosx -ws cocoa -arch x86_64 -consoleLog

!ENTRY org.eclipse.core.resources 2 10035 2015-11-24 11:45:41.741
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
2015-11-24 11:45:42.215 java[548:13214] * WARNING: Method userSpaceScaleFactor in class NSWindow is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
2015-11-24 11:45:42.995 java[548:13214] *
WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
Assertion failed: (backing->lock_access > 0), function CGSBackingStoreUnlockReader, file Services/Windows/CGSBackingStore.c, line 400.

#4 Updated by Anonymous almost 5 years ago

I don't have the problem on Linux...
Your Log mentions "10.7", this could refer to Mac OS X version, in such a case it would be indeed a Mac Issue

#5 Updated by Anonymous about 4 years ago

  • Target version set to AF3 2.10 Post-release

I am also having this issue, but the downloaded application from release is working.

#6 Updated by Simon Barner about 4 years ago

The same assertion is also triggered by a MAC user in the DREAMS project. Here are the steps to reproduce with AF3/DREAMS (MacOSX):

  1. double-click on "System Software" node
  2. click on "annotation" tab.
  3. expand the "System Software" node (or some node below it)
  4. crash

#7 Updated by Simon Barner about 4 years ago

  • Subject changed from Simulation Problem to GC.copyArea() crashes application on OSX 10.11

This seems to be a general problem on recent MacOSX versions and GC.copyArea().

The comment #5 in following link seems to contain a patch which could be backported to the SWT plugin redistributed with Kepler.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=480852#c5

#8 Updated by Anonymous almost 4 years ago

  • Priority changed from Normal to High

#9 Updated by Anonymous almost 4 years ago

  • Assignee changed from Anonymous to Anonymous

#10 Updated by Anonymous almost 4 years ago

Update on OSX 10.11.6:
1) facing the issue in development environment.
2) not facing the issue in the release version for both AF3 and DREAMS.

#11 Updated by Anonymous almost 4 years ago

  • Assignee changed from Anonymous to Anonymous

#12 Updated by Anonymous almost 4 years ago

  • Assignee changed from Anonymous to Anonymous

Sergey can you try with developer and release versions?

#13 Updated by Anonymous almost 4 years ago

  • Assignee changed from Anonymous to Anonymous

#14 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Anonymous
  • Target version changed from AF3 2.10 Post-release to AF3 2.11 Post-release

#15 Updated by Anonymous over 3 years ago

  • Priority changed from High to Low

Not that high:

The error still persists when I run AF3 as developer. But if I run one of the products from the website (nighty build mac64) this error does not occur.

#16 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Anonymous

#17 Updated by Anonymous over 3 years ago

  • Assignee changed from Anonymous to Anonymous

can you assign to somebody relevant? i.e. having a Mac ;-)

#18 Updated by Simon Barner almost 3 years ago

Add workaround to avoid crash in developer version.
A proper fix that requires to update the SWT version (and therefore the target version for the AF3 product) to at least 4.6 (Neon) is under investigation.

#19 Updated by Simon Barner almost 3 years ago

  • Target version changed from AF3 2.12 Post-release to AF3 2.13 RC1 (Feature Freeze)

#20 Updated by Anonymous almost 3 years ago

  • Priority changed from Low to Normal

After the newest svn update the patch doestn work anymore.
When I try to open the AllocatioTable for CA2PA AF3 closes with the following message:

[KISS] Typesystem Service registered.
2017-12-03 17:48:01.906 java[3767:1125941] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
Assertion failed: (backing->lock_access > 0), function CGSBackingStoreUnlockReader, file /BuildRoot/Library/Caches/com.apple.xbs/Sources/SkyLight/SkyLight-312.11/SkyLight/Services/Windows/CGSBackingStore.c, line 360.

#22 Updated by Simon Barner over 2 years ago

  • Target version changed from AF3 2.13 RC1 (Feature Freeze) to AF3 2.13 Release

Since the bug only exists in the developer version, the patch and a documentation should be moved to the Wiki.

#23 Updated by Simon Barner over 2 years ago

  • Status changed from New to Resolved
  • Assignee changed from Simon Barner to Anonymous

Added FAQ entry to https://af3-developer.fortiss.org/projects/autofocus3/wiki/Developer_Installation (installation notes for Mac). It also includes the updated version of the patch.

Can you please close?

#24 Updated by Anonymous over 2 years ago

  • Status changed from Resolved to Closed

#25 Updated by Simon Barner over 2 years ago

  • Status changed from Closed to New
  • Assignee changed from Anonymous to Anonymous
  • Target version changed from AF3 2.13 Release to AF3 2.14 RC1 (Feature Freeze)

The bug has now also been encountered in the AF2.13 binary release (also in the nightly build). Same stack trace as in no 20.

Hence, the patch that is now available from the Wiki should now be integrated into the code base and conditionally be used on Mac.

In the frame of this ticket, also the OS specific case distinctions should be cleaned up
  • Search workspace for string getProperty("os.name")
  • Instead, apply one of the following approaches:
    • Check if org.apache.commons.lang.SystemUtils can be used
    • Extend and use org.fortiss.tooling.base.utils.SystemUtils everywhere. The following platforms need to be distinguished:
      • Win32 (to be discussed if support shall be maintained)
      • Win64
      • Linux64
      • Mac64

#26 Updated by Simon Barner over 2 years ago

  • Status changed from New to Feedback

As mentioned, I quickly fixed this when addressing some other problems with OS/platform-specific case distinctions.

Can you please test if it avoid the crash on your machine? Branch 2443_os-architecture-case-distinctions in af3 and kernel.

#27 Updated by Anonymous over 2 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Anonymous to Simon Barner

Tested. Works now.

#28 Updated by Simon Barner over 2 years ago

I currently cannot create a merge request until he bug in our gitlab installation is resolved.

#30 Updated by Anonymous over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF