Project

General

Profile

Bug #2424

Linux: AnnotationView is not properly updated

Added by Simon Barner about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Start date:
09/07/2015
Due date:
% Done:

100%

Estimated time:

Description

Summary:

Some annotations (i.e. columns) in the AnnotationView
vanish when a model for which the annotations are currently shown is clicked again (after clicking
something else) in the Model Navigator, i.e. the first time a model is
clicked, the number of annotations in the AnnotationView is correct.

Steps to reproduce:

  • Open "Simple Traffic Light Example"
  • Raise annotation view
  • Open component architecture. Observe that annotations are displayed properly (5 columns). See 1.png.
  • Click TL-Requirements. Observe that annotations are displayed properly (2 columns). See 2.png.
  • Click on component architecture again. Observe that some columns are missing. See 3.png.

Note that the annotation view has to be closed and re-opened in order to work around this bug.

2.png (145 KB) 2.png Simon Barner, 09/07/2015 03:48 PM
3.png (146 KB) 3.png Simon Barner, 09/07/2015 03:48 PM
1.png (163 KB) 1.png Simon Barner, 09/07/2015 03:48 PM
Screen Shot 2015-09-08 at 13.41.31.png (21.4 KB) Screen Shot 2015-09-08 at 13.41.31.png Anonymous, 09/08/2015 01:42 PM

History

#1 Updated by Anonymous about 5 years ago

No failure for me :-( so no stack trace

#2 Updated by Anonymous about 5 years ago

  • Assignee changed from Anonymous to Simon Barner

I mean the described behaviour does happen, but there is no exception.

#3 Updated by Anonymous about 5 years ago

I cant reproduce this behavior either. Also when I click on TL-Requirements I have 3 columns (attached pic) ;)

#4 Updated by Simon Barner almost 5 years ago

  • Status changed from New to Feedback
  • Assignee changed from Simon Barner to Anonymous
  • % Done changed from 0 to 50

A workaround has been implemented in r15345. (GenericAnnotationView).

There remains the bug that caching the column width does not work reliably on Linux. However, at least all columns are now displayed in the scenario described in this issue.

Any ideas?

#5 Updated by Simon Barner almost 5 years ago

  • Priority changed from Normal to Low
  • % Done changed from 50 to 100

columnWidthCache is now update in a ControlListener. There, getWidth() seems to always return the true width, and hence the workaround from the last commit is no longer needed (and the width is cached in all cases).

If this fixes the behavior also on your version of Linux, we can consider this bug as resolved (-> please close the bug then).

#6 Updated by Anonymous almost 5 years ago

  • Status changed from Feedback to Closed

works

Also available in: Atom PDF