Project

General

Profile

Bug #2116

Feature #2101: Support for z3lib JNI

Microsoft Z3 plugin is missing native libraries

Added by Florian Hölzl about 6 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
09/02/2014
Due date:
% Done:

100%

Estimated time:

Description

Since the continuous and nightly builds are working again, one problem remains:
com.microsoft.z3 plugin does not ship any native libraries.

I believe these must be added in order for that code to work.

Please, refer to org.fortiss.tooling.graphicsGL.ui plugin for an example
of how to include native libraries in plugins. (And, yes, that long line
in that MANIFEST.MF pointing to the native libs is intentionally a single
line).

History

#1 Updated by Anonymous almost 6 years ago

  • Target version changed from Phoenix 2.7 Release to AF3 2.7 RC4 (bugs fixed)

Is this still a problem?

#2 Updated by Anonymous over 5 years ago

  • Target version changed from AF3 2.7 RC4 (bugs fixed) to AF3 2.8 RC1 (Feature Freeze)

#3 Updated by Anonymous over 5 years ago

  • Target version changed from AF3 2.8 RC1 (Feature Freeze) to AF3 2.8 RC2 (Tested & Bugfixed)

#4 Updated by Anonymous about 5 years ago

  • Assignee changed from Anonymous to Johannes Eder
  • Parent task set to #2101

same issue as parent issue

#5 Updated by Johannes Eder about 5 years ago

  • Target version changed from AF3 2.8 RC2 (Tested & Bugfixed) to AF3 2.9 RC1 (Features frozen)

#6 Updated by Johannes Eder almost 5 years ago

  • Status changed from New to Resolved
  • Assignee changed from Johannes Eder to Florian Hölzl
  • % Done changed from 0 to 100

#7 Updated by Anonymous almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF