Project

General

Profile

Feature #1644

Simulator: save simulation layout for a component

Added by Anonymous about 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
08/23/2013
Due date:
% Done:

100%

Estimated time:

Description

For my model I want to simulate a component that consists of three subcomponents with a state machine for each.
Every time I reopen the simulator I have to reorganize the whole screen, opening three state machines, 1 component view, 2 data variable views and put them so I can see everything. This is very time consuming. So I would like to have the possibility to save the layout for this component.

When I change the name for a component or remove model elements, they can just disappear from my layout. It still would save a lot of time.


Related issues

Related to Change Request #2345: Simulation should use editors and not viewsRejected06/03/2015

History

#1 Updated by Anonymous over 5 years ago

#2 Updated by Anonymous over 5 years ago

  • Assignee changed from Anonymous to Anonymous
  • Target version changed from Phoenix - BACKLOG to AF3 2.10 GUI Improvement Week

That might come automatically if the simulation parts were editors instead of views.

#3 Updated by Johannes Eder over 4 years ago

  • Target version changed from AF3 2.10 GUI Improvement Week to AF3 2.10 Feature Freeze

#4 Updated by Anonymous over 4 years ago

  • Target version changed from AF3 2.10 Feature Freeze to AF3 2.10 Post-release

#5 Updated by Anonymous over 4 years ago

Is it still like this actually? I thought it was saving it

#6 Updated by Anonymous about 4 years ago

  • Target version changed from AF3 2.10 Post-release to AF3 2.11 GUI Improvement Week

#7 Updated by Anonymous almost 4 years ago

  • Status changed from New to Resolved
  • Assignee changed from Anonymous to Alexander Diewald
  • % Done changed from 0 to 100
Since the issue is not so clear, I will attempt to clarify:
  1. open the traffic light
  2. start a simulation through the context menu
  3. open a couple of components, reorganize their windows
  4. go back to modeling perspective
  5. start again a simulation through the context menu

Before: windows are all closed

Now: former windows are still open with the same organization

Fix is a heuristic, but should work most of the time.

#8 Updated by Alexander Diewald almost 4 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Alexander Diewald)

Also available in: Atom PDF