Project

General

Profile

Bug #4022

Creation of safety level constraint throws exception

Added by Martin Eisenmann 5 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Start date:
04/04/2018
Due date:
04/04/2018
% Done:

100%

Estimated time:

Description

To reproduce:
- Open ACC example
- Switch to DSE perspective
- Import ACC project
- Open constraint editor
- Create a safety level constraint for any ECU

Expected behaviour:
- A safety level constraint is created

Obtained behaviour:
- The attached excpeption is thrown and no constraint is created

exception.txt (6.97 KB) exception.txt Martin Eisenmann, 05/14/2020 03:23 PM

Related issues

Follows Change Request #3365: Commonize ExplorationTargetsClosed04/03/2018

History

#1 Updated by Johannes Eder 5 months ago

  • Assignee changed from Johannes Eder to Alexander Diewald

@Alex: Could you please have a look at this issue? I just looked into it and it seems that it happens since the refactoring. When creating a Safety Constraint, the returned ASIL annotation value of a component is null, although it is existing. I have no clue why that happens.

#2 Updated by Alexander Diewald 5 months ago

  • Due date set to 04/04/2018
  • Start date changed from 05/14/2020 to 04/04/2018
  • Follows Change Request #3365: Commonize ExplorationTargets added

#3 Updated by Alexander Diewald 4 months ago

  • Status changed from New to Resolved
  • Assignee changed from Alexander Diewald to Johannes Eder
  • % Done changed from 0 to 100

NOTE: THIS IS A SUCCESSOR OF #4008

(IT IS NOT POSSIBLE TO CREATE A DEPENDENCY)

MR: https://git.fortiss.org/af3/af3/-/merge_requests/338

NOTE: The kernel must be on branch 4008 for this. It will be reviewed and merged next week.

Please test extensively as large parts of the SafetyIntergrityLevel annotation were modified.
  • Test the behavior in the ComponentArchitecture. Also child/parent dominance. Children are not editable while a parent is set to a certain SIL. NOTE: Even if a child has a larger value, it will not be visible until the parent is unset. A child with a higher SIL would break encapsulation concepts.
  • Test the annotation in the PlatformArchitecture.
  • Test the DSE perspective. With the safety standard defined for the PA and not.

There is no test model attached on purpose.

#4 Updated by Johannes Eder about 2 months ago

  • Assignee changed from Johannes Eder to Martin Eisenmann

@Martin: Could you please test if the safety level creation works?

#5 Updated by Martin Eisenmann about 1 month ago

  • Assignee changed from Martin Eisenmann to Johannes Eder

Also available in: Atom PDF