Project

General

Profile

Bug #4021

Broken Routes from the bus minimization / the bus minimization objective does not reduce the number of routes over busses if the objective is defined for one bus

Added by Alexander Diewald 4 months ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
SMT
Start date:
05/14/2020
Due date:
% Done:

0%

Estimated time:
4.00 h

Description

Observed bugs

Assume the following structure:

--Bus-- | |
E E | |
--Bus--

  • When defining a single objective to minimize the number of busses, routes are generated traversing all busses. This implies that selected bus is not minimized.
  • Only when defining two bus minimization targets and including them in the minimization, the number of routes over different busses is minimized.

Discussion

It seems that the bus minimization objective is not operating as intended. According to the observations, it seems that the objective should be defined on a set of Busses to be minimized, which would also improve UX.
However, one of the root of the problem could be that the created expressions refer only to the selected transmission unit, instead of the set of present transmission units (from which only one or more busses selected bus are optimized away).
Another problem to be investigated is the route calculation performed by the solving the optimization problem: In the second example (see below), the route "Route_HeadUnitECU_PowertrainECU" is broken, which can be easily seen in the attached xml.

Example

See attachment. For each of the following setups, allocation constraints were defined that force two communicating Tasks onto different ECUs.
  • Allocation-MinFlex --> 4 different routes present (2 Busses * 2 Directions). NOTE: 4 out of 6 Routes are broken.
  • Allocation-MinFlex+MinGeneric --> 2 different routes present. NOTE: 1 out of 2 Routes are broken.
ACC.af3_23 (1.93 MB) ACC.af3_23 Alexander Diewald, 05/14/2020 02:37 PM

History

#1 Updated by Alexander Diewald 4 months ago

#2 Updated by Alexander Diewald 4 months ago

Attach forgotten example model.

#3 Updated by Johannes Eder 4 months ago

  • Status changed from New to Feedback
  • Assignee changed from Johannes Eder to Alexander Diewald

Important remark: The bus minimization objective is not intended to minimize the number of buses. It is intended to minimize the "bandwidth" of one specific bus by minimizing the summarized signals bandwidths which are sent via the selected bus. Maybe the name of the pattern is misleading and should be changed.

#4 Updated by Alexander Diewald 4 months ago

  • Assignee changed from Alexander Diewald to Johannes Eder

Ouch... That's true... I guess, I mixed things up since related code sometimes called "Bus Minimization" and at other places "Bus Bandwidth Minimization" (from my memory).
I'd propose to name it "Network Utilization Minimization" to avoid such confusion in the future.

What do you think?

For the example, I think that the bandwidth capacity set to equal values (here: zero) has an impact. For non-equal values, all signals should be routed over the network/bus that is not minimized.

Despite that clarification, the route calculation problem is unaffected.

P.S.: Somewhat funny how the ASCII diagram looks in the web version...

#5 Updated by Alexander Diewald 4 months ago

#6 Updated by Johannes Eder about 1 month ago

  • Assignee changed from Johannes Eder to Alexander Diewald

@Alex: Could you please rephrase the broken route problem? I did not really understand it :/

#7 Updated by Alexander Diewald about 1 month ago

  • Status changed from Feedback to Rejected
  • Assignee changed from Alexander Diewald to Johannes Eder

We can reject the issue.

Also available in: Atom PDF