Project

General

Profile

Bug #3982

Hier. Platform: At the tile level, the elements of the upper level are shown

Added by Alexander Diewald 7 months ago. Updated 7 months ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Start date:
03/30/2020
Due date:
04/03/2020
% Done:

0%

Estimated time:
20.00 h

Description

Current status

As title.

Resolution

Check & Fix Compositors/Prototypes, esp the composition rules.

History

#1 Updated by Alexander Diewald 7 months ago

  • % Done changed from 0 to 100

If you have time, otherwise please reassign to me.

Testing: Create a new hierarchical PA down to the Tile level. Notice that Tiles in the Model Element Library any more when editing a tile's content.

MR: https://git.fortiss.org/af3/af3/-/merge_requests/305

#2 Updated by Alexander Diewald 7 months ago

  • Status changed from New to Resolved
  • Assignee changed from Alexander Diewald to Tiziano Munaro

#3 Updated by Tiziano Munaro 7 months ago

  • Assignee changed from Tiziano Munaro to Alexander Diewald

GREEN - Can be merged!

#4 Updated by Alexander Diewald 7 months ago

  • Subject changed from Hier. Platform: At the tile and core level, the elements of the upper level are shown to Hier. Platform: At the tile level, the elements of the upper level are shown
  • Status changed from Resolved to New
  • Assignee changed from Alexander Diewald to Simon Barner
  • Target version changed from AF3 2.17 (Tested, Bug Free) to AF3 2.18 - Feature Freeze
  • % Done changed from 100 to 0
  • Estimated time changed from 1.00 h to 20.00 h

The issue is unresolvable with the current state of the hierarchical platform. The root of the problem is the MemoryUnit that allows "ITileDomain" as its children such that OnChipNetworkPorts can be added to it. This causes Tiles, OnChipNetworks, etc. to be visible at the level of the IProcessorDomain.
The whole logic of showing elements needs to be reconsidered as it is built around the assumption that one type is only present at one distinct level. Therefore, the class-based approach needs to determine the "addability" of a type to some level should be reconsidered as it conflicts a bit with the prototype approach of AF3.
Finally, it could be reconsidered if it is really necessary to define an entire domain (e.g., Tile domain) as child elements of some other domain (e.g., Memory) only to declare the connectors it may contain.

Also available in: Atom PDF