Project

General

Profile

Bug #3961

Missing warnings in data state tab

Added by Johannes Eder 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
03/23/2020
Due date:
% Done:

100%

Estimated time:

Description

Actual behavior:
No warning is displayed if invalid type is entered in Data State tab of State Automatons.

Expected behavior:
There should be a warning (decoration figure/tooltip/label/etc.) indicating that a wrong type is given.

History

#1 Updated by Florian Hölzl 5 months ago

  • Status changed from New to Resolved
  • Assignee changed from Florian Hölzl to Johannes Eder
  • % Done changed from 0 to 90

Added a description label above the table editor, which is used to display error messages when editing the type field.

Branch 3961 contains the changes in kernel and af3.

#2 Updated by Johannes Eder 4 months ago

  • Status changed from Resolved to In Progress
  • Assignee changed from Johannes Eder to Florian Hölzl

@FloH: One small issue remains: If I quit the type field with escape and the type was wrong, the error remains although the type has been reset.

#3 Updated by Johannes Eder 4 months ago

And please create merge requests if the issue is done;)

#4 Updated by Florian Hölzl 4 months ago

Done.

#5 Updated by Florian Hölzl 4 months ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Florian Hölzl to Johannes Eder

#6 Updated by Johannes Eder 4 months ago

  • Assignee changed from Johannes Eder to Alexander Diewald

GREEN. Can be merged.

#7 Updated by Alexander Diewald 4 months ago

  • Assignee changed from Alexander Diewald to Johannes Eder

Merged. Can be closed.

#8 Updated by Alexander Diewald 4 months ago

  • % Done changed from 90 to 100

#9 Updated by Johannes Eder 4 months ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

Also available in: Atom PDF