Project

General

Profile

Bug #3960

Linux specific Bugs in JavaFX editors

Added by Johannes Eder 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/23/2020
Due date:
% Done:

0%

Estimated time:

Description

There are a few bugs which seem to be Linux specific, as they seem to not appear on other platforms.

  • In Listen-Editors(DataDictionary, StateAutomaton->DataState, ModelElements, etc.) selected rows get invisible -> works fine on MacOS
  • Graphic-Glitches (colored lines) on Scrollbars, search windows -> works fine on MacOS
  • Searching via search fileds removes some entries. They dont re-appear when removing clearing the search field. Happens in ModelElementsView -> works fine on MacOS
  • When closing the help windows, it geets unresponsive. has to be closed via force-quit. -> seems to work on Windows and Mac

History

#1 Updated by Florian Hölzl 6 months ago

  • Status changed from New to In Progress
  • In Listen-Editors(DataDictionary, StateAutomaton->DataState, ModelElements, etc.) selected rows get invisible -> works fine on MacOS

Works for me on Ubuntu with Gnome.

  • Graphic-Glitches (colored lines) on Scrollbars, search windows -> works fine on MacOS

Works for me on Ubuntu with Gnome.

  • Searching via search fileds removes some entries. They dont re-appear when removing clearing the search field. Happens in ModelElementsView -> works fine on MacOS

Works for me on Ubuntu with Gnome.

  • When closing the help windows, it geets unresponsive. has to be closed via force-quit. -> seems to work on Windows and Mac

Reproduced on Ubuntu, reason unknown.

All the issues will be checked on Fedora 30/31 later today.

#2 Updated by Florian Hölzl 6 months ago

  • Assignee changed from Florian Hölzl to Johannes Eder
  • In Listen-Editors(DataDictionary, StateAutomaton->DataState, ModelElements, etc.) selected rows get invisible -> works fine on MacOS

Works on Fedora 30.

  • Graphic-Glitches (colored lines) on Scrollbars, search windows -> works fine on MacOS

Works on Fedora 30

  • Searching via search fileds removes some entries. They dont re-appear when removing clearing the search field. Happens in ModelElementsView -> works fine on MacOS

Works on Fedora 30

  • When closing the help windows, it geets unresponsive. has to be closed via force-quit. -> seems to work on Windows and Mac

Reproduced on Fedora 30. Reason unknown.

#3 Updated by Johannes Eder 6 months ago

  • Target version changed from AF3 2.17 (Tested, Bug Free) to AF3 2.18 - Feature Freeze

We will keep this issue to check again before the next release. Closing the help window seems to be a linux specific problem.

#4 Updated by Alexander Diewald 5 months ago

  • Status changed from In Progress to Feedback

Now that the last remaining issue (help page) is resolved in #3989, we should close this issue. The other issues are very GUI-Lib-version-specific, so I think it does not make sense to test for them every release from a coverage perspective.
If some of them shall be kept, it would make more sense to add the items to test to the Core-Test-Cases of the developer wiki.

#5 Updated by Johannes Eder 5 months ago

  • Status changed from Feedback to Resolved
  • Target version changed from AF3 2.18 - Feature Freeze to AF3 2.17 Release

#6 Updated by Johannes Eder 5 months ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

Also available in: Atom PDF