Project

General

Profile

Feature #3955

Decoration Figures in JavaFX Editors

Added by Johannes Eder 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
03/19/2020
Due date:
% Done:

100%

Estimated time:

Description

In the old SWT/GEF editors decoration figures where used to display errors or warnings (model markers), e.g., due to canstraint checks like weak causality etc.
This feature has to be implemented for the new JavaFX-based implementations.

decoration figures in old SWT/GEF impl.

Image Pasted at 2020-3-19 10-34.png (47.2 KB) Image Pasted at 2020-3-19 10-34.png decoration figures in old SWT/GEF impl. Johannes Eder, 03/19/2020 11:16 AM

History

#1 Updated by Florian Hölzl 5 months ago

  • Status changed from New to Feedback
  • Assignee changed from Florian Hölzl to Johannes Eder
  • % Done changed from 0 to 40

A quick solution to this issue is now implemented in branch 3955.
There was some more stuff to be done for channels, while components were rather easy.

I suggest that someone ports this solution to all editors used in the practical course
and we revisit this issue with a proper kernel-based solution when we are getting closer
to version 2.18 release.

Note that the marker service only adds channel type errors to the last segment of a
sequence of channels. In the simple traffic light example, if you introduce a type
mismatch between Merge and Controller component, the error is shown inside the
controller component. Here the constraint checker must be fixed.

#2 Updated by Johannes Eder 5 months ago

  • Assignee changed from Johannes Eder to Florian Hölzl

Florian Hölzl wrote:

A quick solution to this issue is now implemented in branch 3955.
There was some more stuff to be done for channels, while components were rather easy.

I suggest that someone ports this solution to all editors used in the practical course
and we revisit this issue with a proper kernel-based solution when we are getting closer
to version 2.18 release.

I think the component editor + safety cases would be sufficient. We will discuss that in the next JF. -> Create new issue for kernel implementation.

Note that the marker service only adds channel type errors to the last segment of a
sequence of channels. In the simple traffic light example, if you introduce a type
mismatch between Merge and Controller component, the error is shown inside the
controller component. Here the constraint checker must be fixed.

I also discovered that. However, I also discovered why that happens:
if I change the type of an output port, the type of the input port (connected to that output port) also changes automatically (on the same hierarchy level). Is this an intended behavior?

#3 Updated by Alexander Diewald 4 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Florian Hölzl to Johannes Eder
  • % Done changed from 40 to 100

Merged. Please close.

#4 Updated by Johannes Eder 4 months ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

Also available in: Atom PDF