Project

General

Profile

Bug #3933

FX editor not shown for new Component Architectures

Added by Simon Barner 9 months ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
02/05/2020
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce:
  • Create a new project
  • Create a new component architecture
  • Observe that only the GEF-based editor of the CA is opened
  • Double clicking the CA again results into a new tabbed window in which both editors are open
Analysis
  • After all tabs of the CA have been closed, the behaviour is as expected, i.e. both editors are opened, and a CA can only be opened once.
  • This bug seems to be present for CAs, only. Verified for PlatformArchitectures, PartitionArchitectures, TaskArchitectures, and DataDictionaries.

History

#1 Updated by Alexander Diewald 7 months ago

  • Precedes Feature #3995: Implement a switch to load a given DSE in the DSE perspective programatically added

#2 Updated by Alexander Diewald 7 months ago

  • Precedes deleted (Feature #3995: Implement a switch to load a given DSE in the DSE perspective programatically)

#3 Updated by Johannes Eder 6 months ago

  • Status changed from New to Feedback
  • Assignee changed from Johannes Eder to Simon Barner

I guess this issue is fixed. I would reject it.

#4 Updated by Simon Barner 6 months ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Simon Barner to Johannes Eder

Yes, please reject since the GEF editors are gone.

#5 Updated by Johannes Eder 6 months ago

  • Status changed from Resolved to Rejected
  • Assignee deleted (Johannes Eder)

Also available in: Atom PDF