Project

General

Profile

Bug #3766

Constraints contained within an SMTObjective are overwritten during the translation to SMT

Added by Tiziano Munaro over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
07/05/2019
Due date:
% Done:

100%

Estimated time:

Description

Constraints contained within an SMTObjective are overwritten during the translation to SMT in org.fortiss.af3.exploration.smt.modeltransformation.DSMLtoSMTTransformator.transform(ExplorationSpecification, Context).

This is caused by using their shared parent(the dslExpression) as key when storing the SMT expression within both the expressionCache and the transformedExpressions maps (in the constraint loop as well as when adding the minimize/maximize objective itself).

History

#1 Updated by Tiziano Munaro over 1 year ago

  • Status changed from New to In Progress

#2 Updated by Tiziano Munaro over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Tiziano Munaro to Simon Barner
  • % Done changed from 0 to 100

YELLOW

#3 Updated by Simon Barner over 1 year ago

  • Assignee changed from Simon Barner to Johannes Eder
  • Priority changed from High to Normal

#4 Updated by Johannes Eder over 1 year ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

Also available in: Atom PDF