Project

General

Profile

Feature #3608

Support minimization of energy consumption (based on frequency setting) in deployment and scheduling synthesis

Added by Marco Volpe almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
12/28/2018
Due date:
% Done:

100%

Estimated time:

Description

Currently the minimization of energy consumption in deployment and schedule synthesis is simply based on the minimization of latency.
By considering also the frequency assigned to a given ECU as a parameter, a more sophisticated objective can be defined.
This will be enabled for schedule synthesis, as well as for joint deployment and schedule synthesis. In both cases, a solution will now also contain an "optimal" frequency value for each ECU, among a set of admissible values provided by the user (we consider that the frequency of an ECU stays fixed along the whole execution).
In computing the energy consumption, we consider that, for a given ECU, at a given instant, it is quadratically related to the frequency of the ECU.

Existing DSML constraints need to be modified to reflect the changes and new DSML constraints dealing with the frequency need to be introduced.
The feature will be provided for synthesis based on the use of an SMT solver.

AF3-Project-NonHiera.af3_23 (31.3 KB) AF3-Project-NonHiera.af3_23 Model with flat platform Marco Volpe, 08/07/2019 02:59 PM
AF3-Project.af3_23 (131 KB) AF3-Project.af3_23 Model with hierarchical platform Marco Volpe, 08/19/2019 02:35 PM

Related issues

Related to Feature #3310: DSE Deployment(+Schedule) Synthesis with resource specific WCETClosed03/05/2018

History

#1 Updated by Marco Volpe almost 2 years ago

  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to AF3 2.15 RC1 (Feature Freeze)

#2 Updated by Alexander Diewald almost 2 years ago

  • Target version changed from AF3 2.15 RC1 (Feature Freeze) to AF3 2.15 RC1 (Feature Freeze)

#3 Updated by Johannes Eder over 1 year ago

  • Target version changed from AF3 2.15 RC1 (Feature Freeze) to AF3 2.16 RC1 (Feature Freeze)

#4 Updated by Marco Volpe over 1 year ago

  • Related to Feature #3310: DSE Deployment(+Schedule) Synthesis with resource specific WCET added

#5 Updated by Marco Volpe over 1 year ago

  • Target version changed from AF3 2.16 RC1 (Feature Freeze) to Team Programming July 2nd 2019

#6 Updated by Marco Volpe over 1 year ago

  • Target version changed from Team Programming July 2nd 2019 to AF3 2.16 RC1 (Feature Freeze)

#7 Updated by Marco Volpe about 1 year ago

In the context of this feature, the treatment of deployment+schedule and schedule syntheses has been partially unified.
However, pure scheduling is able to consider multi-hop transmissions. Until this gets dealt with also in the joint synthesis (#3361), a complete generalization of the problem is not possible.

#8 Updated by Marco Volpe about 1 year ago

Please find enclosed two models used for testing, one with a hierarchical and one with a flat architecture.
In the case when the architecture is flat it is currently not possible to annotate the execution units with the set of admissible values for the frequency. In those cases, a default value is assigned and there is no actual frequency exploration.

#9 Updated by Marco Volpe about 1 year ago

  • Assignee changed from Marco Volpe to Tiziano Munaro

#10 Updated by Marco Volpe about 1 year ago

  • File deleted (AF3-Project.af3_23)

#11 Updated by Marco Volpe about 1 year ago

Added a new model with hierarchical platform for testing.
Old one was not working anymore due to some changes in the master.

#12 Updated by Tiziano Munaro about 1 year ago

  • Status changed from New to In Progress
  • Assignee changed from Tiziano Munaro to Marco Volpe
  • % Done changed from 0 to 90

#14 Updated by Marco Volpe about 1 year ago

  • Assignee changed from Marco Volpe to Tiziano Munaro

#15 Updated by Tiziano Munaro about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Tiziano Munaro to Alexander Diewald
  • % Done changed from 90 to 100

#16 Updated by Alexander Diewald about 1 year ago

  • Status changed from Resolved to Closed

All GREEN and Merged. Thanks a lot!

Also available in: Atom PDF