Project

General

Profile

Change Request #3473

Schedule constraint generation should use TA2HW allocation as input

Added by Simon Barner about 2 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/05/2018
Due date:
% Done:

0%

Estimated time:

Description

ScheduleRun::generateBasicScheduleConstraints() etc. currently uses SuperSet<ResourceAllocation> as input.

This should be changed to:
  • TaskToExecutionUnitAllocationEntry
  • ports-to-transceivers (depends on #3223)

The requires a change of dseproject.ecore->ScheduleDSERun->searchSpaceResourceAllocations

History

#1 Updated by Marco Volpe almost 2 years ago

  • Related to Change Request #3551: In the formulation of a scheduling problem, replace ResourceAllocations with Tasks and Signals added

#2 Updated by Johannes Eder over 1 year ago

  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to Backlog

#3 Updated by Simon Barner over 1 year ago

  • Status changed from New to Resolved
  • Assignee changed from Simon Barner to Johannes Eder

Please reject: duplicate of #3551

#4 Updated by Johannes Eder over 1 year ago

  • Status changed from Resolved to Rejected
  • Assignee deleted (Johannes Eder)

#5 Updated by Alexander Diewald 12 months ago

  • Related to deleted (Change Request #3551: In the formulation of a scheduling problem, replace ResourceAllocations with Tasks and Signals)

Also available in: Atom PDF