Project

General

Profile

Feature #3433

Auto Layouter: Consider label size

Added by Simon Barner over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
06/08/2018
Due date:
% Done:

0%

Estimated time:

Description

Problem description:

  • Create CA
  • Create Component labeled "Component1Component1Component1"
  • Perform automatic layout (in context menu of CA)

Observe that label of Component is truncated

The auto layouter should be extended that the length of the label is correctly considered.

AF3-Project.af3_23 (8.99 KB) AF3-Project.af3_23 test case for label width requirements of elements and connections Simon Barner, 06/11/2018 01:31 PM

Related issues

Related to Feature #2588: [GUI] Multi-line componentsNew05/23/2016

History

#1 Updated by Simon Barner over 2 years ago

Implemented: https://git.fortiss.org/af3/kernel/merge_requests/6

The attachment contains a test case that demonstrates that the label width requirements of both elements and connections is considered.

#2 Updated by Anonymous over 2 years ago

  • Assignee changed from Anonymous to Simon Barner

I guess you are talking about the name in the graphical representation (i.e. in the case of the component, the box).
For the tabs size works correctly.
For the boxes, the solution works but it requires a refresh of the view by e.g. an Automatic layout.
The refresh thing is a problem that has appeared in the past.
I can live with this solution if an automatic refresh is not easy.

#3 Updated by Simon Barner over 2 years ago

I am not sure that I have understood your comment. What are tabs and boxes?

I have made some improvements affects e.g. for Component Architecture. If a CA that has already been opened is layouted from the model navigator, ensure that not another tab with the root level of the CA is displayed.

Implemented in

#4 Updated by Simon Barner over 2 years ago

  • Assignee changed from Simon Barner to Anonymous

#5 Updated by Anonymous over 2 years ago

An editor is shown as a tab. For this, the layout works perfectly because as soon as you increase the size of the name, the size of this tab increases.
The other thing I'm talking about is the graphical representation of models. E.g. from the component architecture view, a component is a box. Here when you increase the length of the name, "..." are added when the complete name can not be displayed and only when an explicit refresh is used (e.g. by automatic layout) the size of the component (box) is increased

#6 Updated by Simon Barner over 2 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Anonymous to Florian Hölzl

Ok, you want to automatically resize the element edit part when its name changes.

@Flo: What do you think about this? If you like it: How could it be implemented?

#7 Updated by Anonymous over 2 years ago

This is what I managed to do by making the name long and applying automatic layout, but now I'm not able to reproduce anymore.
This was proposed in an old issue, but I cannot find it now. That isue was actually suggesting to split the label in several lines instead of expanding the component.

#8 Updated by Simon Barner over 2 years ago

#9 Updated by Simon Barner over 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Florian Hölzl to Anonymous

I think you refer to #2588. See there for additional comments.

I suggest to not mix these two aspects and consider this issue (that is about autolayout) as resolved.

#10 Updated by Anonymous over 2 years ago

  • Status changed from In Progress to Resolved

#11 Updated by Anonymous over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF