Project

General

Profile

Feature #3310

DSE Deployment(+Schedule) Synthesis with resource specific WCET

Added by Johannes Eder over 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
03/05/2018
Due date:
% Done:

0%

Estimated time:

Description

Currently, deployments and the joint deployment+scheduling synthesis considers only the generic, execution unit independent WCET (duration).

However, in the Task-To-Execution Table a specific WCET for each task to execution unit allocation can be given.
The DSE deployment and the deployment+scheduling synthesis should be extented such that either the generic or (resource) specific WCET values may be used for synthesis.


Related issues

Related to Feature #3608: Support minimization of energy consumption (based on frequency setting) in deployment and scheduling synthesisClosed12/28/2018

History

#1 Updated by Marco Volpe over 1 year ago

  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to AF3 2.15 RC1 (Feature Freeze)

#2 Updated by Alexander Diewald over 1 year ago

  • Target version changed from AF3 2.15 RC1 (Feature Freeze) to AF3 2.15 RC1 (Feature Freeze)

#3 Updated by Johannes Eder over 1 year ago

  • Target version changed from AF3 2.15 RC1 (Feature Freeze) to AF3 2.16 RC1 (Feature Freeze)

#4 Updated by Simon Barner over 1 year ago

  • Subject changed from DSE Schedule Synthesis with resource specific WCET to DSE Deployment(+Schedule) Synthesis with resource specific WCET

For pure scheduling, the original issue has been resolved in the frame of #3361.

However, also for pure deployment (where WCETs can be used determine the load of an execution unit) and the joint deployment+scheduling synthesis, the execution unit specific WCETs for Task s should be considered.

The execution unit independent Wcet annotation of the Task may be used as fallback in case no specific WCETs have been obtained (see Task.getWcet(ExecutionUnit)).

#5 Updated by Simon Barner over 1 year ago

  • Description updated (diff)

#6 Updated by Marco Volpe about 1 year ago

  • Related to Feature #3608: Support minimization of energy consumption (based on frequency setting) in deployment and scheduling synthesis added

#7 Updated by Marco Volpe about 1 year ago

For deployment+scheduling, the issue is being resolved in the context of #3608.

#8 Updated by Marco Volpe 12 months ago

  • Target version changed from AF3 2.16 RC1 (Feature Freeze) to AF3 2.17 (Feature Freeze)

#9 Updated by Marco Volpe 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Marco Volpe to Johannes Eder

Hi Johannes, this issue has been solved in the context of #3361 (for schedule synthesis) and #3608 (for deployment + schedule synthesis).
I think it can be closed/rejected.

#10 Updated by Johannes Eder 10 months ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Johannes Eder)

Also available in: Atom PDF