Project

General

Profile

Feature #3120

removing "use case"

Added by Tatiana Chuprina almost 3 years ago. Updated 10 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
04/11/2018
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

"use case aspect" has been already removed from the menu of Requirements (from registerPrimaryPrototype) (see, how it was in "use case aspect.jpg").

Due to code freeze, there is no possibility to remove the respective GUI now.
It should be done in next release.

use case aspect.jpg (47.4 KB) use case aspect.jpg Tatiana Chuprina, 10/26/2017 01:56 PM

Subtasks

Support #3379: Removing Use Cases from MIRA Rejected

History

#1 Updated by Anonymous almost 3 years ago

  • Assignee changed from Anonymous to Anonymous

#2 Updated by Anonymous almost 3 years ago

  • Assignee changed from Anonymous to Anonymous

The GUI has already been updated.
However I think we are not using use cases at all.
@Vince: shall we try to get rid of all the code about use cases?

#3 Updated by Anonymous almost 3 years ago

Agreed in principle, but might be worth discussing with Tatiana: she made a literature survey on requirements engineering, and maybe she could argue if she thinks we need to keep them.

#4 Updated by Tatiana Chuprina over 2 years ago

  • Status changed from New to Resolved

Guys, I would leave it. At least for some time, because "use cases" are a part of MIRA framework. We can, perhaps, stash this code.

#5 Updated by Anonymous over 2 years ago

  • Assignee changed from Anonymous to Anonymous

I suspect that the code referring to use cases might be marked already as "deprecated".
@Filip: can you lease confirm?

#6 Updated by Anonymous over 2 years ago

There is no deprecated code in mira and mira.ui plugins

#7 Updated by Anonymous over 2 years ago

There is a package org.fortiss.af3.mira.model.usecase.impl which is the one that I think is obsolete.
However it is not marked as deprecated because some generated code is referring to it.
We might need to remove "usecase" from the mira model, see that nothing is broken, and then get rid of this classes.

#8 Updated by Anonymous over 2 years ago

  • Status changed from Resolved to Closed

Removed all the code concerned with Use Case.

From the SimpleTrafficLightsExample and STLC Beagle Java Deployments examples
were removed the Use Case requirements.

#9 Updated by Anonymous over 2 years ago

  • Status changed from Closed to In Progress
  • Target version changed from AF4 Requirements to AF3 2.13 RC2 (Tested, Bug-free)

@Filip: I re-open this issue because Johannes explained me yesterday that this is not the correct way of doing this (I was having a similar problem after renaming testing.method.random).
The use case is part of the meta model and therefore present in every old project that was using it (as it was the case with simple traffic light).
If now someone tries to load an old project, it will not and the will go a null pointer in the console.

What it needs to be done is to write a migrator. Here there is a small explanation.
https://af3-developer.fortiss.org/projects/autofocus3/wiki/Model_Migration

#10 Updated by Simon Barner over 2 years ago

  • Target version changed from AF3 2.13 RC2 (Tested, Bug-free) to AF3 2.14 RC1 (Feature Freeze)

The metamodel has been restored (classes marked as deprecated), and the migrator is in place.

Moving the ticket to AF2.13 post release, so the migrator and the use case metamodel can be removed for good.

#11 Updated by Anonymous over 2 years ago

  • Status changed from In Progress to Resolved

This issue duplicates the issue #3379

#12 Updated by Anonymous over 2 years ago

  • Status changed from Resolved to Closed

#13 Updated by Anonymous over 2 years ago

  • Status changed from Closed to Feedback

There are still references to UseCase in the code.
And UseCase is still in the model
Also the migrator needs to be removed

#14 Updated by Anonymous over 2 years ago

By the way, since you are the developer of this issue, you should not be the one closing it. Whenever the issue is resolved, you can assign it to me and I'll review it and close it

#15 Updated by Johannes Eder over 1 year ago

  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to Backlog

#16 Updated by Johannes Eder about 1 year ago

  • Assignee changed from Anonymous to Johannes Eder

#17 Updated by Johannes Eder 10 months ago

  • Status changed from Feedback to Rejected
  • Assignee deleted (Johannes Eder)

Rejected, due to the fact the mira will be refactored to a minimal version.

Also available in: Atom PDF