Project

General

Profile

Bug #3111

[Constraint] Constraint instances are not deleted on disabling the constraint

Added by Anonymous about 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/19/2017
Due date:
% Done:

0%

Estimated time:

Description

When a constraint is disabled, its instance should be deleted. It is not the case at the moment.

History

#1 Updated by Anonymous about 3 years ago

I would reject because otherwise, AF3 will forget the status.

Take the following scenario:
  1. activate reachability constraint
    -> a constraint instance is added and checked immediatly - might take a long time
  2. deactivate the constraint
    -> State today: nothing happens, instance stays
    -> State 3111: instance is deleted
  3. reactivate the constraint
    -> State today: nothing happens, since the instance is still here
    -> State 3111: instance is recreated and check needs to be done again

Bottom line: it's a feature, not a bug :-)

#2 Updated by Anonymous about 3 years ago

  • Status changed from New to Rejected
  • Assignee deleted (Anonymous)

Also available in: Atom PDF