Project

General

Profile

Bug #3070

Problem with importing the Demonstrator AF3-Project

Added by Anonymous about 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/08/2017
Due date:
% Done:

0%

Estimated time:

Description

I am trying to import the AF3 Model (attached) of our Demonstrator. It doesn't work and the error message says something about TaskArchitecture. Please take a look.

!MESSAGE Exception while loading model file: PikeOS_Demonstrator_ExclusiveBusAccessAndJoystick.af3_23
!STACK 0
org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Value 'org.fortiss.af3.timing.model.annotation.impl.TransmissionUnitBandwidthImpl@588d9e13 (id: 4646, name: null, bandwidth_MBytesPerSecond: 0.0)' is not legal. (platform:/resource/AF3-Project-Directory/PikeOS_Demonstrator_ExclusiveBusAccessAndJoystick.af3_23, -1, -1)
at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.handleErrors(XMLLoadImpl.java:77)
at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:185)
at org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.java:261)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1518)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1297)
at org.fortiss.tooling.kernel.internal.storage.eclipse.ModelContext.<init>(ModelContext.java:121)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EclipseResourceStorageService.loadContext(EclipseResourceStorageService.java:284)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EclipseResourceStorageService.access$1(EclipseResourceStorageService.java:282)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EclipseResourceStorageService$1.runInWorkspace(EclipseResourceStorageService.java:215)
at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
Caused by: org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'org.fortiss.af3.timing.model.annotation.impl.TransmissionUnitBandwidthImpl@588d9e13 (id: 4646, name: null, bandwidth_MBytesPerSecond: 0.0)' is not legal. (platform:/resource/AF3-Project-Directory/PikeOS_Demonstrator_ExclusiveBusAccessAndJoystick.af3_23, -1, -1)
at org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XMLHandler.java:2697)
at org.eclipse.emf.ecore.xmi.impl.XMLHandler.handleForwardReferences(XMLHandler.java:1175)
at org.eclipse.emf.ecore.xmi.impl.XMLHandler.endDocument(XMLHandler.java:1264)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.endDocument(AbstractSAXParser.java:745)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:841)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:770)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:141)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1213)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:643)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(SAXParserImpl.java:327)
at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:175)
... 9 more
Caused by: java.lang.ClassCastException: org.fortiss.af3.timing.model.annotation.impl.TransmissionUnitBandwidthImpl cannot be cast to org.fortiss.af3.task.model.TaskArchitecture
at org.fortiss.af3.exploration.projectmodel.impl.DSEImpl.eSet(DSEImpl.java:601)
at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eSet(BasicEObjectImpl.java:1071)
at org.eclipse.emf.ecore.xmi.impl.XMLHelperImpl.setValue(XMLHelperImpl.java:1204)
at org.eclipse.emf.ecore.xmi.impl.XMLHandler.setFeatureValue(XMLHandler.java:2692)
... 20 more

History

#1 Updated by Johannes Eder over 2 years ago

  • Status changed from New to Feedback
  • Assignee changed from Johannes Eder to Anonymous

Is this issue still relevant?

#2 Updated by Simon Barner about 1 year ago

  • Status changed from Feedback to Rejected
  • Assignee deleted (Anonymous)
  • Target version set to Backlog

Also available in: Atom PDF