Project

General

Profile

Bug #3003

Change Request #3878: [UI] Collection task to switch gef based editors to the new JavaFX-based editors (LWFXEF)

Feature #3815: [Kernel] Add LWFXEF framework from SystemFOCUS to kernel.common.ui

[GUI] connecting ports

Added by Anonymous about 3 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
07/25/2017
Due date:
% Done:

0%

Estimated time:

Description

In order to connect two ports p1 and p2, one has to start from p1, press the mouse and drag it to p2.
If p1 is connected to some port p3 with a wired p1-p3, it would be nice to allow to connect p2 by dragging the mouse over the wire p1-p3.

Also one cannot from an input to an output; we have to start from the output and drag he mouse to the input.
Would be useful to allow both directions

History

#1 Updated by Florian Hölzl about 3 years ago

  • Target version set to DevTools-NG

#2 Updated by Florian Hölzl over 2 years ago

  • Target version changed from DevTools-NG to AF3 2.13 RC1 (Feature Freeze)

#3 Updated by Florian Hölzl over 2 years ago

  • Target version changed from AF3 2.13 RC1 (Feature Freeze) to AF3 2.14 RC2 (Tested, Bug-free)

#4 Updated by Johannes Eder about 1 year ago

  • Target version changed from AF3 2.14 RC2 (Tested, Bug-free) to Backlog

#5 Updated by Johannes Eder about 1 year ago

  • Target version changed from Backlog to AF3 2.16 RC1 (Feature Freeze)

#6 Updated by Johannes Eder about 1 year ago

  • Target version changed from AF3 2.16 RC1 (Feature Freeze) to AF3 2.16 RC2 (Tested, Bug-free)

#7 Updated by Florian Hölzl about 1 year ago

  • Target version changed from AF3 2.16 RC2 (Tested, Bug-free) to AF4 Requirements

#8 Updated by Simon Barner 10 months ago

  • Parent task set to #3815

Maybe this can be considered as a requirement for the new implementation.

#9 Updated by Johannes Eder 6 months ago

  • Status changed from New to Rejected
  • Assignee deleted (Florian Hölzl)

Not a bug. If necessary in the future, new feature request has to be created.

Also available in: Atom PDF