Project

General

Profile

Bug #2198

MIRA: Exception in createTraceNotAnalyzedViolation

Added by Anonymous almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Start date:
01/13/2015
Due date:
% Done:

100%

Estimated time:

Description

1. Open attached model

Then following exception occures:

!ENTRY org.eclipse.core.jobs 4 2 2015-01-13 13:11:53.412
!MESSAGE An internal error occurred during: "Model Constraint Checker Job".
!STACK 0
java.lang.StringIndexOutOfBoundsException: String index out of range: -2
at java.lang.String.substring(Unknown Source)
at org.fortiss.af3.mira.utils.MiraUtils.getTraceNameString(MiraUtils.java:824)
at org.fortiss.af3.mira.verification.ConstraintMessage.createTraceNotAnalyzedViolation(ConstraintMessage.java:171)
at org.fortiss.af3.mira.verification.RequirementTraceAnalyzedChecker.apply(RequirementTraceAnalyzedChecker.java:51)
at org.fortiss.af3.mira.verification.RequirementTraceAnalyzedChecker.apply(RequirementTraceAnalyzedChecker.java:1)
at org.fortiss.tooling.kernel.internal.ConstraintCheckerService.performConstraintCheck(ConstraintCheckerService.java:92)
at org.fortiss.tooling.kernel.internal.ConstraintCheckerService.performAllConstraintChecksRecursively(ConstraintCheckerService.java:61)
at org.fortiss.tooling.kernel.utils.ServicesUtils.performAllConstraintChecksRecursively(ServicesUtils.java:40)
at org.fortiss.tooling.kernel.ui.internal.MarkerService.refreshMarkers(MarkerService.java:188)
at org.fortiss.tooling.kernel.ui.internal.MarkerService$2.run(MarkerService.java:117)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

History

#1 Updated by Anonymous almost 6 years ago

  • Priority changed from Normal to High

#2 Updated by Anonymous almost 6 years ago

  • Status changed from New to Resolved
  • Assignee changed from Anonymous to Anonymous
  • % Done changed from 0 to 70

The issue is fixed, but the model has an unspecified external trace that can't be found in any requirement as you can see in the first trace of the Traces section in the Requirements Analysis overview. Is this intended?

#3 Updated by Anonymous almost 6 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 70 to 100

Test OK. These traces are unintended (new tracker).

Also available in: Atom PDF