Project

General

Profile

Bug #2136

[Test] Test generation raising exception

Added by Anonymous about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
09/22/2014
Due date:
% Done:

0%

Estimated time:

Description

Steps to reproduce:
  1. open the attached model
  2. open the component architecture
  3. open the component
  4. open the test suite specification
  5. check "State Coverage"
  6. generate a test suite

Obtained:
- an empty test suite

Expected:
- a non empty test suite

Further remarks:
- the same happens for the "Transition Coverage" case
- another bug happens for the "Random Input" case

AF3-Project.af3_23 (16.7 KB) AF3-Project.af3_23 Anonymous, 09/22/2014 05:30 PM

History

#1 Updated by Anonymous almost 6 years ago

  • Assignee changed from Anonymous to Georgeta Igna

#2 Updated by Georgeta Igna over 5 years ago

  • Status changed from New to Resolved
  • Assignee changed from Georgeta Igna to Anonymous

1) The guards should also contain a check that Input!=NoVal

2) The problem was in method createTestStep(TestCase testCase) from org.fortiss.af3.testing.utils.TestingModelElementFactory always returns a null value for the component defined at this line:
Component parent = KernelModelElementUtils.getParentElement(testCase, Component.class);
which always returned null.

Now, there is a work around, but some side effects could occur.

#3 Updated by Anonymous over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF