Project

General

Profile

Feature #2064

Initial Message for Ports can not be defined for nested Array

Added by Andreas Bayha over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
07/23/2014
Due date:
% Done:

100%

Estimated time:

Description

In the appended project, the port Input is of a complex type, containing an Array.
The initial message for this port can nither be generated; nor can it be saved if entered manually.

NestedArrays.af3_23 (9.21 KB) NestedArrays.af3_23 Andreas Bayha, 07/23/2014 10:01 AM
NestedArrays.af3_23 (11.6 KB) NestedArrays.af3_23 Anonymous, 01/27/2015 05:53 PM

History

#1 Updated by Anonymous almost 6 years ago

  • Assignee set to Anonymous
  • Target version changed from Phoenix 2.7 Release to AF3 2.7 RC4 (bugs fixed)

#2 Updated by Anonymous over 5 years ago

  • Assignee changed from Anonymous to Anonymous

#3 Updated by Anonymous over 5 years ago

  • File NestedArrays.af3_23 NestedArrays.af3_23 added
  • Tracker changed from Bug to Feature
  • Status changed from New to Feedback
  • Assignee changed from Anonymous to Andreas Bayha
  • % Done changed from 0 to 100

In my opinion, it's not a bug, but rather a feature :)
I try to explain it on the "Input" port:
The port has MyStruct2 as type. This type consists of y:(EnumElement), x:(y:Array, x:int).
You try todeclare y:(EnumElement), x:(y:int,x:int) instead ... that doesnt work ;)

gl&hf with the attached model

#4 Updated by Andreas Bayha over 5 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (Andreas Bayha)

The problem only occured on my linux system.

It seamed, that the actual reason was a problem with file access rights (for the AF3 project)...

Also available in: Atom PDF