Project

General

Profile

Bug #2041

Toolbar layout is broken

Added by Simon Barner over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
07/03/2014
Due date:
% Done:

100%

Estimated time:

Description

The layout of the AF3 toolbar is broken (see attached image: )

(At least I see this on 32-bit Kepler on Windows 7)

toolbar_layout.png (27.5 KB) toolbar_layout.png Simon Barner, 07/03/2014 03:03 PM
FirstOpen.JPG (46.1 KB) FirstOpen.JPG Toolbar in a fresh workspace Alexander Diewald, 07/04/2014 09:24 AM
SecondOpen.JPG (39.8 KB) SecondOpen.JPG Toolbar when launching AF3 the second time Alexander Diewald, 07/04/2014 09:24 AM
3rdOpen.JPG (38.8 KB) 3rdOpen.JPG Toolbar when launching AF3 the 3rd time Alexander Diewald, 07/04/2014 09:25 AM

History

#1 Updated by Simon Barner over 6 years ago

  • Status changed from New to Closed

The problem seems to have been caused by an old runtime workspace. I reported the bug since resetting the (modeling) perspective did not fix this. Closing.

#2 Updated by Alexander Diewald over 6 years ago

Please reopen this bug. The issue is still present when starting with a fresh workspace.

The main issue here is the AF3 toolbar wandering around in the top bar. It moves whenever AF3 has been closed and is reopened. Sometimes it is required to open a Component Architecture to see this happen.

To illustrate this issue, I attached some screenshots.
From a newly created workspace (by AF3 itself) the UI looks as expected:
Toolbar in a fresh workspace

Upon closing AF3 regularly (using window's close button) the toolbar is shifted to the right:
Toolbar when launching AF3 the second time

After the third launch, there is also additional space between the perspective button an the toolbar:
Toolbar when launching AF3 the 3rd time

This additional space seems to incrementally add up and cause a behaviour like in Simon's screenshot.

#3 Updated by Anonymous over 6 years ago

  • Status changed from Closed to New
  • Target version changed from AF3 2.6 RC3 Quality fixed to AF3 2.6 RC2 Kepler bug fixes

#4 Updated by Anonymous over 6 years ago

  • Status changed from New to Resolved
  • Assignee set to Anonymous
  • % Done changed from 0 to 100

No official workaround.

Made an ugly patch in the line of a solution presented here: http://www.eclipse.org/forums/index.php/t/366870/ (message by Sergey Kuznetsov on Wed, 19 March 2014 08:39). Seems to work.

#5 Updated by Anonymous over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF