Project

General

Profile

Bug #2031

Model-Checking: if no else exists for an if-statement in code specification for model-checking, the checker throws an exception

Added by Anonymous over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
06/20/2014
Due date:
% Done:

100%

Estimated time:

Description

Additionally, the exception has no meaningful name.

Maybe the model-checker could add an empty "else"?

History

#1 Updated by Anonymous over 6 years ago

  • Subject changed from Model-Checking: if no else exists in modelchecking, the checker throws an exception to Model-Checking: if no else exists for an if-statement in code specification for model-checking, the checker throws an exception

#2 Updated by Anonymous over 6 years ago

  • Target version changed from Phoenix 2.6 Release to AF3 2.6 RC3 Quality fixed

#3 Updated by Anonymous over 6 years ago

  • Assignee deleted (Anonymous)

#4 Updated by Andreas Bayha over 6 years ago

  • Assignee set to Andreas Bayha

#5 Updated by Andreas Bayha over 6 years ago

  • Assignee changed from Andreas Bayha to Anonymous

Hi Sabine!

I tryed to reproduce this Bug. However I was not able to do so.

Can you provide the example, that produced the error?

#6 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Andreas Bayha

Example sent:-)

#7 Updated by Anonymous over 6 years ago

  • Assignee changed from Andreas Bayha to Anonymous

I have commited a bug-fix for this issue (hopefully). At least it works for me now. Sabine, can you verify it?

#8 Updated by Anonymous over 6 years ago

  • Status changed from New to Resolved

#9 Updated by Anonymous over 6 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Seems to work!

Also available in: Atom PDF