Project

General

Profile

Feature #1987

MIRA: SWT-Bot for traces between requirements

Added by Anonymous over 6 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
03/18/2014
Due date:
% Done:

100%

Estimated time:

Description

Please overwork the SWT-Bot for all features related with traces between requirements.

Error.png (241 KB) Error.png Anonymous, 04/08/2015 11:57 AM

History

#1 Updated by Anonymous over 6 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 40

#2 Updated by Anonymous over 6 years ago

  • Target version changed from Phoenix 2.6 Release to AF3 2.6 RC1 Feature Freeze

#3 Updated by Anonymous over 6 years ago

  • Target version changed from AF3 2.6 RC1 Feature Freeze to Phoenix 2.7 Release

Not closed for feature freeze ==> move to AF3 2.7

PLEASE DO NOT COMMIT ANYTHING RELATED TO THIS ISSUE UNTIL THE 2.6 RELEASE

#4 Updated by Anonymous about 6 years ago

- why do we need EditorTest and MiraHelpTest?
- check source code of MiraHelpTest for TODOs and solve them
- remove or rework commented code
- make MiraHelpTest executable

#5 Updated by Anonymous about 6 years ago

  • % Done changed from 40 to 80

#6 Updated by Anonymous almost 6 years ago

  • Target version changed from Phoenix 2.7 Release to AF3 2.7 RC3 (tested)

#7 Updated by Anonymous almost 6 years ago

  • Target version changed from AF3 2.7 RC3 (tested) to AF3 2.7 RC4 (bugs fixed)

#8 Updated by Anonymous over 5 years ago

  • Target version changed from AF3 2.7 RC4 (bugs fixed) to Phoenix 2.7 Release

#9 Updated by Anonymous over 5 years ago

  • Target version changed from Phoenix 2.7 Release to AF3 2.8 RC1 (Feature Freeze)

#10 Updated by Anonymous over 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Anonymous to Anonymous

#11 Updated by Anonymous over 5 years ago

  • File Error.png Error.png added
  • Status changed from Resolved to Feedback
  • Assignee changed from Anonymous to Anonymous

SWTBot-Test does not work (see attached picture)

#12 Updated by Anonymous over 5 years ago

  • Assignee changed from Anonymous to Anonymous

#13 Updated by Anonymous about 5 years ago

  • Status changed from Feedback to In Progress
  • Target version changed from AF3 2.8 RC1 (Feature Freeze) to AF3 2.8 Post-release

Please do not use "Feedback" anymore: it's either "New", "In Progress", "Resolved" or "Closed". Otherwise I don't know if the issue should be assigned to a tester or a developer.

#14 Updated by Anonymous about 5 years ago

Status?

#15 Updated by Anonymous about 5 years ago

  • Target version changed from AF3 2.8 Post-release to AF3 2.9 RC1 (Features frozen)

#16 Updated by Johannes Eder almost 5 years ago

  • Assignee changed from Anonymous to Johannes Eder

#17 Updated by Anonymous almost 5 years ago

  • Assignee changed from Johannes Eder to Anonymous

#18 Updated by Anonymous almost 5 years ago

still failing

#19 Updated by Johannes Eder almost 5 years ago

The Problem maybe caused by a wrong focus of the running application (http://wiki.eclipse.org/SWTBot/Troubleshooting). If AF3 does not have focus SWTBot takes the development eclipse which is obviously the wrong one. However I could not solve this bug. Maybe we have to run the test from command line.

#20 Updated by Johannes Eder over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Anonymous to Anonymous
  • % Done changed from 80 to 100

Removed the tests because they do not work on any OS and can not be fixed in reasonable time.

#21 Updated by Anonymous over 4 years ago

  • Status changed from Resolved to Rejected

Also available in: Atom PDF