Project

General

Profile

Bug #1971

MIRA: Error when copying components in the component architecture

Added by Anonymous over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
03/03/2014
Due date:
% Done:

100%

Estimated time:

Description

When you copy a component in the component architecture (not in MIRA) that has a ExternalRelationSpecification, the ExternalRelationSpecification is copied but not valid any more.

The ExternalRelationSpecification should not be copied at all. Existing invalid ExternalRelationSpecifications should be deleted (with warning).


Related issues

Related to Feature #1865: MIRA: Copy traces when copying requirementsRejected12/12/2013

History

#1 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

#2 Updated by Anonymous over 6 years ago

  • Status changed from New to Resolved
  • Assignee changed from Anonymous to Anonymous
  • % Done changed from 0 to 80

Added dependency to org.fortiss.af3.mira in org.fortiss.component.ui. It works fine for my build, but could you check if dependencies occur?

#3 Updated by Anonymous over 6 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Anonymous to Anonymous

It does not work on my computer.
For example,
I take the SimpleTrafficLightExample.
When I copy the component called "Behavior", the ExternalRelationSpecification also is copied.
When I double-click on the ExternalRelationSpecification, a Null-Pointer-Exception occurs.

#4 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

Should work properly now, but there is no prevention of copying the invalid references when copying the component yet.

#5 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

Please check again:)

#6 Updated by Anonymous over 6 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Anonymous to Anonymous

#7 Updated by Anonymous over 6 years ago

  • Subject changed from Error when copying components in the component architecture (MIRA) to MIRA: Error when copying components in the component architecture
  • Status changed from In Progress to Resolved
  • Assignee changed from Anonymous to Anonymous

Should work properly now. I fixed a bug, when copying a component with link to requirement directly under the component architecture. Please test also and close.
I agreed on the dependency of component.ui to mira with Moudy.

#8 Updated by Anonymous over 6 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 80 to 100

#9 Updated by Anonymous over 6 years ago

  • Assignee deleted (Anonymous)

#10 Updated by Anonymous over 6 years ago

  • Target version changed from Phoenix 2.6 Release to AF3 2.6 RC3 Quality fixed

Also available in: Atom PDF