Project

General

Profile

Feature #1831

MIRA: connect informal traces and formal refinement

Added by Anonymous almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
11/11/2013
Due date:
% Done:

100%

Estimated time:

Description

1. Add radio button #1832
2. Add button in MIRA to connect traces and formal refinements #1858

Component.PNG (29.7 KB) Component.PNG Anonymous, 04/01/2014 05:01 PM
layout.PNG (16.4 KB) layout.PNG Anonymous, 04/01/2014 05:03 PM

Related issues

Related to Feature #1832: MIRA: Traces section - use radio button to choose rowClosed11/11/2013

Related to Feature #1858: MIRA: button to open "Refinement Specification" dialog from tracesClosed12/09/2013

History

#1 Updated by Anonymous almost 7 years ago

  • Subject changed from MIRA: connect informal and formal refinement to MIRA: connect informal traces and formal refinement

#2 Updated by Anonymous almost 7 years ago

  • Description updated (diff)

#3 Updated by Anonymous almost 7 years ago

  • Assignee changed from Anonymous to Anonymous

#4 Updated by Anonymous almost 7 years ago

  • Target version changed from Phoenix - BACKLOG to Phoenix 2.5 Release

#5 Updated by Anonymous almost 7 years ago

  • Target version changed from Phoenix 2.5 Release to Phoenix 2.5 (RC1 - Feature Freeze)

#6 Updated by Anonymous almost 7 years ago

  • Target version changed from Phoenix 2.5 (RC1 - Feature Freeze) to Phoenix - BACKLOG

#7 Updated by Anonymous over 6 years ago

  • Status changed from New to Resolved
  • Assignee changed from Anonymous to Anonymous
  • % Done changed from 0 to 80

#8 Updated by Anonymous over 6 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from Anonymous to Anonymous

Please just drop by the next days and show me, how it works. I am somehow not able to test it.

#9 Updated by Anonymous over 6 years ago

Please add warnings when a) no formal specification exists, b) no component in formal specification exists.

Please refer to source and target requirements in dialogs.

#10 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

#11 Updated by Anonymous over 6 years ago

When adding a refinement specification by this button there are two differences to "normal" creation of the refinement specification (for both "traces within requirements" and "traces to architecture":
- layout: the newly created refinement specification has no layout, everything is on top of each other (see attached picture layout.png).
- component: between the formal specification and the model there is a "component" I have to open (see attached picture component.png).

#12 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous
  • Target version changed from Phoenix - BACKLOG to Phoenix 2.6 Release

#13 Updated by Anonymous over 6 years ago

  • Target version changed from Phoenix 2.6 Release to AF3 2.6 RC1 Feature Freeze

#14 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

#15 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

Exception when clicking "Add refinement specification":

!ENTRY org.eclipse.emf.common 2 0 2014-06-27 11:12:59.085
!MESSAGE An exception was ignored during command execution
!STACK 0
org.eclipse.emf.common.util.WrappedException: An exception was ignored during command execution
at org.eclipse.emf.common.command.BasicCommandStack.handleError(BasicCommandStack.java:281)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.handleError(AbstractTransactionalCommandStack.java:125)
at org.eclipse.emf.common.command.BasicCommandStack.execute(BasicCommandStack.java:112)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.basicExecute(AbstractTransactionalCommandStack.java:241)
at org.eclipse.emf.transaction.impl.TransactionalCommandStackImpl.doExecute(TransactionalCommandStackImpl.java:63)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.execute(AbstractTransactionalCommandStack.java:165)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.execute(AbstractTransactionalCommandStack.java:219)
at org.fortiss.tooling.kernel.internal.storage.eclipse.AutoUndoCommandStack.execute(AutoUndoCommandStack.java:84)
at org.fortiss.tooling.kernel.internal.storage.eclipse.ModelContext.runAsCommand(ModelContext.java:249)
at org.fortiss.tooling.kernel.internal.CommandStackService.runAsCommand(CommandStackService.java:65)
at org.fortiss.af3.mira.ui.action.CreateRefSpecAction.run(CreateRefSpecAction.java:73)
at org.fortiss.af3.mira.ui.editor.relation.RelationSection$3.widgetSelected(RelationSection.java:603)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:138)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:610)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.fortiss.af3.rcp.application.AF3Application.start(AF3Application.java:48)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Caused by: java.lang.NullPointerException
at org.fortiss.tooling.kernel.internal.ElementCompositorService.compose(ElementCompositorService.java:68)
at org.fortiss.af3.mira.ui.action.CreateRefSpecAction$addRefSpecToComponentAction.run(CreateRefSpecAction.java:107)
at org.fortiss.tooling.kernel.internal.storage.eclipse.ModelContext$2.execute(ModelContext.java:258)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EMFTransactionalCommand$1.doExecute(EMFTransactionalCommand.java:60)
at org.eclipse.emf.transaction.RecordingCommand.execute(RecordingCommand.java:135)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EMFTransactionalCommand$2.run(EMFTransactionalCommand.java:72)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EMFTransactionalCommand.runInTransaction(EMFTransactionalCommand.java:104)
at org.fortiss.tooling.kernel.internal.storage.eclipse.EMFTransactionalCommand.execute(EMFTransactionalCommand.java:69)
at org.eclipse.emf.common.command.BasicCommandStack.execute(BasicCommandStack.java:78)
... 36 more

!ENTRY org.eclipse.emf.common 2 0 2014-06-27 11:12:59.095
!MESSAGE An exception was ignored during command execution
!STACK 0
org.eclipse.emf.common.util.WrappedException: An exception was ignored during command execution
at org.eclipse.emf.common.command.BasicCommandStack.handleError(BasicCommandStack.java:281)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.handleError(AbstractTransactionalCommandStack.java:125)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.execute(AbstractTransactionalCommandStack.java:229)
at org.fortiss.tooling.kernel.internal.storage.eclipse.AutoUndoCommandStack.execute(AutoUndoCommandStack.java:84)
at org.fortiss.tooling.kernel.internal.storage.eclipse.ModelContext.runAsCommand(ModelContext.java:249)
at org.fortiss.tooling.kernel.internal.CommandStackService.runAsCommand(CommandStackService.java:65)
at org.fortiss.af3.mira.ui.action.CreateRefSpecAction.run(CreateRefSpecAction.java:73)
at org.fortiss.af3.mira.ui.editor.relation.RelationSection$3.widgetSelected(RelationSection.java:603)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4170)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3759)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:138)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:610)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.fortiss.af3.rcp.application.AF3Application.start(AF3Application.java:48)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Caused by: org.eclipse.emf.transaction.RollbackException:
at org.eclipse.emf.transaction.impl.TransactionImpl.commit(TransactionImpl.java:405)
at org.eclipse.emf.transaction.impl.TransactionalCommandStackImpl.doExecute(TransactionalCommandStackImpl.java:70)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.execute(AbstractTransactionalCommandStack.java:165)
at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.execute(AbstractTransactionalCommandStack.java:219)
... 32 more

#16 Updated by Anonymous over 6 years ago

  • Assignee changed from Anonymous to Anonymous

#17 Updated by Anonymous over 6 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (Anonymous)
  • % Done changed from 80 to 100

Test OK

Also available in: Atom PDF