Project

General

Profile

Bug #1560

InputPort for complex struct can not be assigned an initial value

Added by Andreas Bayha about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
08/01/2013
Due date:
% Done:

100%

Estimated time:

Description

In the appended project, the only InputPort "Input" is of type MyStruct, which contains an enumeration as a member (member y).

It is not possible to assign an initial value to this port.

AF3-Project.af3_23 (4.29 KB) AF3-Project.af3_23 Andreas Bayha, 08/01/2013 05:36 PM

History

#1 Updated by Andreas Bayha about 7 years ago

  • Assignee set to Anonymous

#2 Updated by Anonymous about 7 years ago

  • Assignee changed from Anonymous to Anonymous
  • Target version set to Phoenix 2.4 RC3 (Review Phase)

#3 Updated by Andreas Bayha about 7 years ago

The same applies for ports with arrays of an enumeration.

#4 Updated by Anonymous about 7 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

improved the feature with common handler and supporting for enum type

#5 Updated by Anonymous about 7 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Anonymous to Andreas Bayha

can you check whether the bug is resolved on your side?

#6 Updated by Andreas Bayha about 7 years ago

  • Assignee changed from Andreas Bayha to Anonymous

The bugs does not occur on my examples anymore, either...

#7 Updated by Andreas Bayha about 7 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 90 to 100

Also available in: Atom PDF