Project

General

Profile

Bug #1491

Intuitive binding of (undo/redo) actions

Added by Anonymous over 7 years ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Category:
Hackathon
Start date:
07/16/2013
Due date:
% Done:

0%

Estimated time:

Description

Undo/redo and their hotkey are only working if focus is on an item in Model Navigator. Except Component Architecture Editor, if focus is on any other editor, the undo/redo function is not working.

History

#1 Updated by Anonymous about 6 years ago

  • Status changed from New to Rejected

Can't reproduce/don't understand

#2 Updated by Simon Barner almost 6 years ago

  • Subject changed from Undo/redo bug to Undo/redo bug when deleting elements from Model Navigator
  • Status changed from Rejected to New
  • Assignee deleted (Anonymous)
  • Target version set to AF3 2.7 RC2 (GUI improved)

Reopening since this bug is still present.

Steps to reproduce

  1. Create a new project
  2. Create a component architecture
  3. Add a component
  4. Select (click onto) the component in the model navigator
  5. Delete the component (e.g., using the context menu or the DEL key)
  6. Observe that undo does not work (CTRL+Z has no effect, Undo is grayed out in the Edit menu)
Analysis / suggested workaround:
  • The problems seems to occur because after the delete operation, no object is selected.
  • Hence, a possible workaround is to ensure that the selection is not empty, e.g. by programmatically setting the selection to the container of the deleted object in the model navigator

#3 Updated by Anonymous almost 6 years ago

  • Assignee set to Simon Barner
  • Priority changed from Normal to Low

#4 Updated by Simon Barner almost 6 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Implemented a workaround to ensure that the selection of the NavigatorViewPart is never empty.

#5 Updated by Simon Barner almost 6 years ago

  • Tracker changed from Bug to Feature
  • Status changed from Closed to New
  • Assignee deleted (Simon Barner)
  • Priority changed from Low to Normal
  • Target version changed from AF3 2.7 RC2 (GUI improved) to AF3 2.8 RC1 (Feature Freeze)
  • Reopening, because the old (partial) and now reverted workaround NavigatorViewPart (for this issue) and also the workaround in DiagramEditorBase (for #2207 and this issue) are only partial
  • Summing up:
    • Undo/redo of operations on the model only works if either the NavigatorViewPart or a DiagramEditorBase has the focus
    • This makes sense if the active view provides editable items itself (e.g., the GenericAnnotationView) and provides undo/redo (currently not the case for GenericAnnotationView).
    • For other (read-only) view (e.g., Model Markers), this behavior is confusing for the user
  • Desired feature
    • Provide undo/redo also for those cases from above where undo/redo is currently disabled.
    • The context of the action binding should be "most intuitive" to the user, e.g. restrict undo/redo to the scope of editable views, and bind theses action to the model level for read-only views

#6 Updated by Simon Barner almost 6 years ago

  • Subject changed from Undo/redo bug when deleting elements from Model Navigator to Intuitive binding of (undo/redo) actions
  • % Done changed from 100 to 30

#7 Updated by Simon Barner almost 6 years ago

Workaround to NavigatorViewPart had to be re-enabled. It also seems to fix #2203

#8 Updated by Anonymous about 5 years ago

  • Target version changed from AF3 2.8 RC1 (Feature Freeze) to AF3 2.10 GUI Improvement Week

#9 Updated by Johannes Eder over 4 years ago

  • Target version changed from AF3 2.10 GUI Improvement Week to AF3 2.10 Feature Freeze

#10 Updated by Johannes Eder over 4 years ago

  • Tracker changed from Feature to Bug
  • Assignee set to Florian Hölzl
  • Target version changed from AF3 2.10 Feature Freeze to AF3 2.10 Post-release

#11 Updated by Florian Hölzl almost 4 years ago

  • Target version changed from AF3 2.10 Post-release to AF3 2.11 Post-release

#12 Updated by Florian Hölzl over 2 years ago

  • Target version changed from AF3 2.11 Post-release to AF3 2.14 RC1 (Feature Freeze)

#13 Updated by Johannes Eder over 1 year ago

  • Target version changed from AF3 2.14 RC1 (Feature Freeze) to Backlog

#14 Updated by Johannes Eder over 1 year ago

  • Target version changed from Backlog to AF3 2.16 RC1 (Feature Freeze)

#15 Updated by Johannes Eder over 1 year ago

  • Target version changed from AF3 2.16 RC1 (Feature Freeze) to AF3 2.16 RC2 (Tested, Bug-free)

#16 Updated by Florian Hölzl over 1 year ago

  • Category set to Hackathon
  • % Done changed from 30 to 0

#17 Updated by Florian Hölzl about 1 year ago

  • Target version changed from AF3 2.16 RC2 (Tested, Bug-free) to AF3 2.17 (Tested, Bug Free)

#18 Updated by Johannes Eder 6 months ago

  • Target version changed from AF3 2.17 (Tested, Bug Free) to AF3 2.18 - Critical bugs fixed

Also available in: Atom PDF