Project

General

Profile

Bug #1140

Support #975: Usability Testing and Feedback

Support #1108: Testing the implementation of arrays

during simulation, next value of an array cannot be edited, because "Invalid Type" error

Added by Anonymous almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
01/10/2013
Due date:
% Done:

100%

Estimated time:

Description

see attached screenshot

simerror2.png (18.8 KB) simerror2.png Anonymous, 01/10/2013 01:32 PM

Related issues

Blocks Bug #1139: during simulation, array[ 3 ] is set to NoVal and not to [NoVal, NoVal, NoVal]Closed01/10/2013

History

#1 Updated by Anonymous almost 8 years ago

  • Status changed from New to Feedback
  • Assignee changed from Anonymous to Anonymous
  • % Done changed from 0 to 90

problem fixed by modifying FastTypeChecker

#2 Updated by Anonymous almost 8 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Anonymous to Anonymous
  • % Done changed from 90 to 70

when setting Next value in Simulator, the next value is immediately copied to Current value (for all kinds of variables), regardless if the component is weak or strong.

#3 Updated by Anonymous almost 8 years ago

  • Assignee changed from Anonymous to Florian Hölzl
  • % Done changed from 70 to 90

This behavior exists since the first day of AF3 Phoenix. I think it is by design. Am I Right?

#4 Updated by Anonymous almost 8 years ago

The next value to input ports is without any delay taken into consideration.

The causality affects only output ports.

#5 Updated by Anonymous almost 8 years ago

  • Assignee changed from Florian Hölzl to Anonymous
  • % Done changed from 90 to 80

I will test it today again

#6 Updated by Anonymous almost 8 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 80 to 100

Also available in: Atom PDF