Project

General

Profile

Bug #1083

Copy-paste does not work at all in the editor.

Added by Anonymous almost 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Start date:
01/16/2012
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Subtasks

Bug #505: Non-intuitive copy and paste from Mode substructure to component substructureClosed

History

#1 Updated by Anonymous almost 8 years ago

  • Assignee set to Anonymous

This happens in the case of e.g. components -- paste does not function in the editor.

#2 Updated by Anonymous almost 8 years ago

  • Status changed from New to In Progress

copy/paste worked e.g. for StateAutomaton, but not for ComponentArchitecture. Resolved problem in ComponentCompositor.
Also changed that a pasted componend is added with a minor layout offset to the original one.

Problem was located here:
org.fortiss.af3.component.utils.ComponentArchitectureUtils.hasBehaviorDefinitionSpecification(Component)

Entry-Point to Test:
org.fortiss.tooling.kernel.ui.util.CopyPasteUtils.canPasteInto(EObject, IElementCompositionContext)

See also:
org.fortiss.tooling.kernel.ui.internal.ActionService
org.fortiss.tooling.kernel.internal.ElementCompositorService.findWorkingCompositor(EObject, EObject, IElementCompositionContext, boolean)
org.fortiss.af3.component.ui.compose.ComponentCompositor.canCompose(Component, EObject, IElementCompositionContext)

#3 Updated by Anonymous almost 8 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Anonymous to Anonymous

please test if it works like you would expect

#4 Updated by Anonymous almost 8 years ago

however, sub-issue #505 is not resolved yet

#5 Updated by Anonymous almost 8 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF