Project

General

Profile

Bug #1032

Multiple Platform Architectures not Supported in Deployment Mapping

Added by Bernhard Schätz almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
11/16/2012
Due date:
% Done:

100%

Estimated time:

Description

If an AF3 Component Architecure has already been mapped via a Deployment to a Platform Architecture, the definition of a second mapping via drag/drop for an alternative Platform Architecture is not possible in the Component-ECU-Mapping View.
In the Raw Mappings Pane, the definition of a new assignment does not work, because the secdond alternative Platform Architecture is not offered in the dialog (even it is already selected in the ECU-Component-Mapping view).

History

#1 Updated by Anonymous almost 8 years ago

  • Assignee set to Florian Hölzl

#2 Updated by Anonymous almost 8 years ago

  • Target version changed from Phoenix 2.3 Release to Phoenix 2.3 RC2 (Major Bugs)

#3 Updated by Florian Hölzl almost 8 years ago

  • Status changed from New to Feedback
  • Assignee changed from Florian Hölzl to Bernhard Schätz

Please clarify the problematic case:
a) the problem occurs with a second deployment (using the same LA, but a different PA) in the same model
b) the problem occurs when changing in a given deployment from one PA to another
c) the intention was to use one LA with two PAs in a single deployment (i.e. two components go to PA_1 and three others to PA_2).

#4 Updated by Bernhard Schätz almost 8 years ago

Case a) was intended -- having one LA already deployed to one PA, and then adding a second PA to have an alternative deplyoment.

#5 Updated by Florian Hölzl almost 8 years ago

  • Assignee changed from Bernhard Schätz to Florian Hölzl

Next time, please change the assignee of the issue back to the person requesting feedback, so such an issue shows up on his or her list of open issues.

#6 Updated by Florian Hölzl almost 8 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Florian Hölzl to Anonymous
  • % Done changed from 0 to 70

Bug was fixed, by changing several methods in af.deployment.util.DeploymentUtils.

Several methods have been deprecated and replaced with equivalent methods, which have the deployment object as an additional parameter.
The deprecated methods are still used in

  • af3.sil
  • af3.scheduling

Please check these implementations and change them if possible.

#7 Updated by Anonymous over 7 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from Anonymous to Florian Hölzl
  • % Done changed from 70 to 100

#8 Updated by Anonymous over 7 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Florian Hölzl)

Also available in: Atom PDF